View Issue Details

IDProjectCategoryView StatusLast Update
0017850MediaMonkey 5Track Browserpublic2021-06-25 19:31
Reportermichal Assigned To 
PriorityurgentSeverityminorReproducibilitysometimes
Status closedResolutionreopened 
Product Version5.0.1 
Target Version5.0.1Fixed in Version5.0.1 
Summary0017850: Auto-scroll to the selected item in Column filter after the change
DescriptionWe are trying to keep selection in column filter lists, after any change in column filter, where possible (just like iTunes). But it sometimes leads to the situation, where selected item is not in the visible area of the list. We should automatically scroll to the first selected item after such change.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?p=481310#p481310
TagsNo tags attached.
Fixed in build2419

Relationships

related to 0015265 closedmichal Column browser: The second column isn't reset to "all" when value in the first column is changed (sometimes) 

Activities

michal

2021-05-11 17:40

developer   ~0063135

Fixed in build 2403.

lowlander

2021-06-18 03:25

developer   ~0063992

Last edited: 2021-06-18 03:25

View 2 revisions

1) Selecting an item in item in column 2 and unffiltering in column 1 fails
1 Select item in column 2
2 Select an item in column 1 that includes item selected in column 2
--> Selected item in column 2 is in view
3 Select All in column 1
--> Selected item in column 2 is not in view

Tested with Genre > Artist > Album columns in Column Filter

michal

2021-06-18 14:28

developer   ~0063996

Test note - it seems, that very quick click (short time between mousedown and mouseup) is needed to reproduce.

michal

2021-06-18 15:41

developer   ~0063999

Fixed in the build 2418.

lowlander

2021-06-18 19:41

developer   ~0064000

Still present on 2418 for me.

Tried in the Year > 2018 node set to List view with Column Filter enabled.
1 Go to 2018 node in Year
2 Select Alan Jackson in second column
3 Select Country in first column
--> Alan Jackson is shown first in visible area, good!
4 Select All in first column
--> Alan Jackson is no longer visible

Note that after 4 I've also seen:
--> Selected item in column 2 in the visible area, but at the bottom instead of top

rusty

2021-06-18 19:54

administrator   ~0064003

For me, build 2418 is worse than 2417. Now the issue crops up fairly regularly, whereas previously it was the exception rather than the rule.

michal

2021-06-20 15:17

developer   ~0064027

Fixed in build 2419. I cannot reproduce it with any given steps finally.

lowlander

2021-06-25 19:31

developer   ~0064069

Verified on 2419