View Issue Details

IDProjectCategoryView StatusLast Update
0015265MediaMonkey 5Main Panelpublic2021-05-11 17:45
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015265: Column browser: The second column isn't reset to "all" when value in the first column is changed (sometimes)
DescriptionWhen the column browser columns are [Genre|Artist|Album]
then selecting another genre doesn't reset artist column to all. Sometimes only visually, sometimes also the values are filtered.
Screenshot: https://www.dropbox.com/s/2wt9zniiokcsfl0/hilite%20problem.png?dl=0
TagsNo tags attached.
Fixed in build2140

Relationships

related to 0014608 closedpetr Focus persistence issues when deleting tracks 
related to 0017850 closedmichal Auto-scroll to the selected item in Column filter after the change 

Activities

michal

2018-12-14 14:22

developer   ~0051781

Last edited: 2018-12-14 14:24

View 2 revisions

It is regression caused by fix from 0014608 item 2).

michal

2018-12-14 16:56

developer   ~0051783

Fixed in build 2140.

peke

2018-12-21 01:07

developer   ~0051851

Verified 2143

Ludek

2019-02-27 13:00

developer   ~0052817

Last edited: 2019-02-27 13:33

View 2 revisions

Re-opened, this isn't fully fixed, details in https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=93948&p=456159#p456156

At first I couldn't replicate, but then I realized that the issue happens only for the last row in the first column

michal

2019-02-27 13:53

developer   ~0052820

It is feature. It tries to keep selection, where it is possible, e.g. where the value in the second column persists after change in first column.
But it was always reset to All in MM4, so maybe it will be better to do it same way.

michal

2019-02-27 16:50

developer   ~0052822

Per offline discussion with Jiri, leaving this as feature. It works the same in iTunes.

peke

2019-05-20 22:36

developer   ~0053582

Retested in 2176

This feature works the same in iTunes, closing for now.