View Issue Details

IDProjectCategoryView StatusLast Update
0017836MediaMonkey 5Otherpublic2021-07-12 21:07
Reporterlowlander Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionnot fixable 
Product Version5.0 
Target Version5.0.1Fixed in Version5.0.1 
Summary0017836: Web > AllMusic hangs MM / Other nodes cause abnormal termination
DescriptionWhen opening AllMusic in the Web node in MediaMonkey the whole program hangs.
Additional InformationTicket 1455 1616 1667 2107
TagsNo tags attached.
Fixed in build2403

Relationships

related to 0017120 closedLudek Remove HD tracks from MM 
related to 0016256 closedpetr Improve default sites in Webnodes list 
related to 0016159 closedpetr Web node issues (including freeze) 
related to 0018066 newpetr Expand Web node functionality 

Activities

Ludek

2021-05-10 13:46

developer   ~0063118

I can confirm, accessing Web > All music
=> memory utilized by MM5 grows constantly, UI is frozen and crash log is generated after 30 seconds

Ludek

2021-05-10 14:13

developer   ~0063119

Last edited: 2021-05-10 14:15

View 3 revisions

So far I haven't found why accessing 'AllMusic.com' causes whole UI thread to freeze, probably something from the amount of advertisements or pop-up windows on the AllMusic site somehow hooks the renderer process.

As a short term solution for 5.0.1.2403 I removed 'All Music.com' from MediaMonkey > Web bookmarks.
=> Fixed in 5.0.1.2403

As for the long term solution: Currently we use embedded window for opening the web bookmarks, it would be probably better to take the Chrome's approach and start separate process for each third party web site?
Assigned to Petr for evaluation/revision post 5.0.1

rusty

2021-05-11 19:51

administrator   ~0063138

Last edited: 2021-05-11 20:27

View 2 revisions

Verified that the node is removed from 2403. However,

We may want to re-examine this for 5.0.1 since there's a related issue for the other web nodes in which visiting them causes MM to terminate abnormally:
1 run MM
2 Navigate to the amazon or iheart node and stay there for a few seconds)
3 Close MM
--> it takes > 30s to close (in contrast to < 5s normally) !

Ludek

2021-05-12 18:29

developer   ~0063153

Last edited: 2021-05-12 18:31

View 2 revisions

Petr indicated that the AllMusic.com freeze happens even with the Chromium's sample app.

But we cannot replicate the 30s to close issue, assigned to Rusty to generate log/video.

Also, can you test whether it is replicable with release (non-debug) build ?

rusty

2021-05-20 01:12

administrator   ~0063305

I'm no longer able to replicate the 30s to close issue. Re-assigning to Petr for triage (i.e. is the issue considered fixed or are additional changes planned in the future so that allmusic works correctly).

petr

2021-05-20 13:17

developer   ~0063317

Based on fact that chromium sample app freezes as well while opening allmusic.com page it can be hard to find a solution .. so for now i will not do anything with that.

lowlander

2021-05-26 16:37

developer   ~0063497

If a user happens on this crash, the following should get user out of restart crash loop:
1) Start MediaMonkey
2) Click any node in the Media Tree immediately
3) Close MediaMonkey immediately after
Then restarting MediaMonkey will work