View Issue Details

IDProjectCategoryView StatusLast Update
0016159MediaMonkey 5Main Panelpublic2020-05-28 15:49
ReporterLudek Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionreopened 
PlatformWindowsOS-OS Version10
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016159: Web node issues (including freeze)
Description1) Accessing "All music" causes MM to freeze: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95502 (freeze log 5E8A8314)

2) Another web site cannot be added to the Web node ("Add new Bookmark" context menu from MM4 is missing): https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95505

3) Bookmarks cannot be removed/renamed like in MM4: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95504
Additional InformationMerged all related Topic into one for better tracking https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95505
TagsNo tags attached.
Fixed in build2252

Activities

petr

2019-12-09 14:02

developer   ~0055613

Items 2&3 implemented

Ludek

2019-12-17 17:34

developer   ~0055718

Last edited: 2019-12-17 17:58

View 3 revisions

User is still getting freezes/crashes while accessing the amazon web pages, logs and details:
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95576&sid=49ede02175f8733ed01b703724f4fbdf
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95577

If that's not fixable then I would suggest to open the pages in another window or embed the window with the default web browser?

EDIT: User is also requesting ability to re-order the bookmarks by D&D : https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95578
This sounds rather as a low priority item to me (as it did not work in MM4 too)

Ludek

2020-01-02 17:20

developer   ~0055783

Peke merged the topics, so the links above are broken, new link is https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=95505

petr

2020-04-30 09:40

developer   ~0057790

Retest freeze in 2244 please as i cannot reproduce (probably because of chromium update ?).

rusty

2020-05-13 20:49

administrator   ~0057995

Tested 2247 and verified the 3 issues (mostly).

Remaining:
3b) Unless I'm overlooking it, there doesn't seem to be a way to choose/rename the link title. i.e. when the user enters a link to a website, the dialog should show:
Enter a Website Link: _____________________________
Title: ____<auto-filled and editable title>___________

New:
4) The context menu for all child webnodes contains a bunch of irrelevant commands (i.e. everything but 'add new bookmark' and 'remove bookmark'
5) The context menu somehow operates on files that aren't selected! e.g. Right-click on 'Last FM' and then 'Auto-organize' --> MM somehow performs auto-organize on a bunch of files that aren't selected! Fixing 4) will resolve this issue, however I've documented it separately in case this issue is a selection problem that occurs in other as-yet undiscovered cases.

petr

2020-05-14 16:46

developer   ~0058006

Fixed

rusty

2020-05-18 23:57

administrator   ~0058095

Verified 2250. Just a minor issue re. item 3b): the formatting if the dialog is a bit off. It should appear as:

Add Bookmark:
Website Link: ___________________
Title: ____________________________

petr

2020-05-19 10:31

developer   ~0058108

Fixed

peke

2020-05-22 23:16

developer   ~0058217

Verified 2251

rusty

2020-05-24 03:51

administrator   ~0058236

Minor issue remains: The text 'boxes' should be aligned.

petr

2020-05-24 08:56

developer   ~0058238

Fixed

peke

2020-05-28 01:09

developer   ~0058327

Verified 2252

For me they look good now.