View Issue Details

IDProjectCategoryView StatusLast Update
0017831MediaMonkey 5Extensionspublic2021-05-21 22:05
Reporterdrakinite Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.1 
Target Version5.0.1Fixed in Version5.0.1 
Summary0017831: Config panels load the wrong scripts
DescriptionExample causing a crash: Log ID: 14D1FC2F

When opening and closing multiple addon config panels, they can load the wrong scripts.
To reproduce:
1) Add the two config panel test scripts (attached to issue) to Scripts folder
2) open DbgView and filter for "ConfigTest" (The two test scripts simply make logs when they load and save)
3) Open Tools>Addons and search for "config"
4) Open panel for Config test 1 and close it
5) Open panel for Config test 2 and close it
6) Repeat
Step 4) results in expected log messages: Panel 1 successfully loads and saves; 5) also results in Panel 2 successfully loading and saving.
However, when reopening Config test 1 (in step 6), the Panel 2 config script loads, resulting in ConfigTest: Load: 2 and ConfigTest: Save: 2 messages repeating indefinitely.
[Alternatively: you can also open the chrome console on step 4 and view the logs there]

Since the scripts can depend on HTML elements in the panel, if the wrong script is loaded, it can result in a crash.
TagsNo tags attached.
Fixed in build2406

Activities

drakinite

2021-05-18 01:55

developer   ~0063263

Ludek

2021-05-18 19:12

developer   ~0063271

Fixed

drakinite

2021-05-21 20:45

developer   ~0063371

Verified 2406