View Issue Details

IDProjectCategoryView StatusLast Update
0017830Addons (external)Generalpublic2021-12-18 01:37
Reporterrusty Assigned To 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0.2Fixed in Version5.0.2 
Summary0017830: Edit tag script: Clean multiple attributes
DescriptionOften, fields with multiple attributes (Artists, Album Artist, Genres) are populated with attributes containing incorrect separators (e.g. ',' or '/' instead of ';').

It would be useful to have a script that allowed the user to quickly convert the separators to the proper format.

e.g.
Clean multiple attribute fields
This script converts separators to the proper format. e.g. Artist1, Artist2 to Artist1; Artist2 OR Rock/Pop to Rock;Pop

Options:
Switch the following characters to separators: _,_

Access via: Edit tags > Clean multi-attribute separators
TagsNo tags attached.

Relationships

related to 0017829 closeddrakinite Edit tag script: Split Artists from Title 

Activities

drakinite

2021-06-26 04:38

developer   ~0064078

Added initial version to SampleScripts for 5.0.2. I moved the "Case Checker" item to order: 100, because that one feels like it should be toward the bottom of the group.

Assigning to Ludek for review. My only concern with my code is that the interface freezes for a short time when editing a large number of tracks. Not sure if that's acceptable or if it's something to work on.

Ludek

2021-06-28 12:20

developer   ~0064087

Last edited: 2021-06-28 12:22

View 2 revisions

Reviewed and made some optimizations + added cancelable progress (SVN revision 38237)

Maybe we could move it from SampleScripts to Scripts -- to be the default (pre-installed) script like the Case Checker and others ?

drakinite

2021-06-28 21:42

developer   ~0064091

Addon has been moved to Scripts/ for 5.0.2 and added to the addon site here: https://www.mediamonkey.com/addons/browse/item/clean-multi-value-fields/

lowlander

2021-09-28 17:26

developer   ~0064893

Verified on 2506.

rusty

2021-10-24 21:54

administrator   ~0065479

Last edited: 2021-10-26 00:55

View 4 revisions

I'd suggest a couple of improvements/changes to the addon:

1) Text changes:
a) Clean Multi-Value Fields --> Split multi-value fields
b) Switch the following to separators --> Split fields containing (this is closer to the terminology in Tools > Options > Tags)

2) We may want to initially launch this as an addon (rather than integrated into MM) since there are quite a few new strings (and since they're liable to change).

3) Combine this with the Featured Artist to Artist addon:

Clean multi-value fields
-----------------------------------------------------
Split strings so that they display as multiple values.

Artists, Album Artists, Albums, Composers, ... (list of all multiple-value fields):
[x] Split fields containing: _,_
[x] Split fields containing: _+_
[x] Split fields containing: _&_
[ ] Split fields containing: _and_

Artists:
[x] Split fields containing (comma-separated list): _feat, ft, featuring_

4) For the future it might make sense to allow the user to choose which fields to apply splitters to. e.g.

Split multi-value fields
---------------------------------------------------------------------------
Split strings so that they display as multiple values.

[x] Split _Artists, Composers_ containing: _,_
[x] Split _Artists_ containing: _+_
[x] Split _Artists, Album Artists_ containing: _&_
[x] Split _Artists_ containing: _feat, ft, featuring_ for _Artists_ [Edit]
[ ] Split <choose fields> containing: _enter a single character, or comma-separated strings_
[+] [-]

drakinite

2021-11-04 01:00

developer   ~0065699

Strings updated. I couldn't fit all of the multi-value fields in one line, so I used your short list and programmatically added the full list as a tooltip.

drakinite

2021-11-04 22:16

developer   ~0065728

Addon has been moved to RemovedScripts

peke

2021-12-18 01:37

developer   ~0066407

verified 2528