View Issue Details

IDProjectCategoryView StatusLast Update
0017829Addons (external)Generalpublic2021-12-18 01:36
Reporterrusty Assigned To 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionreopened 
Product Version5.0.1 
Target Version5.0.2Fixed in Version5.0.2 
Summary0017829: Edit tag script: Split Artists from Title
DescriptionThis is an idea for a simple script (that could, at some point in the future be included in MM).

Musicbrainz and other metadata sources often title tracks in the following format:

Title (feat. Artist)
Title (feat. Artist1 and Artist2)

Auto-tag already processes such tracks correctly (i.e. if a lookup is successful, featured artists are moved to the Artist field), but in cases where auto-tag fails or isn't used, it would be useful if users could manually apply such a rule.

This could be accessed via:
- Edit tags > Title (feat. Artist) to Artist (Tooltip: Moves featured artists from the Title to the Artists field)

Note:
1) Other tracks might also appear as follows and shouldn't be changed:
Title (Remix)
Title (xxxxx version)

2) 'feat.' might be used similarly in other languages in which case it should be applied in a similar fashion (can probably be deferred)

Peke:
3) In some other cases using other online sources for files and for Audio CDs, there is also common case where "feat.", "ft.", and if there is multiple featuring artists also "," is used to separate additional featuring artists.
Additional InformationBased on comments at: https://www.mediamonkey.com/forum/viewtopic.php?f=33&t=98957
TagsNo tags attached.

Relationships

related to 0017830 closeddrakinite Edit tag script: Clean multiple attributes 

Activities

drakinite

2021-06-29 03:25

developer   ~0064096

Created edit tag script and put into Scripts. If a track has multiple featured artists, e.g. Title (feat. Artist1 and Artist2) they can first use this script to put it in the correct field, then use the Clean Multi-Value Fields script from 0017829 to convert Artist1 and Artist2 into Artist1; Artist2.

Assigning to Ludek for review.

Ludek

2021-10-14 11:00

developer   ~0065196

Resolving in order to test by Peke whether it works correctly.

rusty

2021-11-03 13:38

administrator   ~0065675

btw, one other change i that you can re-use existing strings re. field names and the example. i.e.

Title tag --> Title
Artist tag --> Artist

And for the examples wouldn't it make sense to use concrete ones based on the first selected track. An example of this is in Auto-Organize > [Configure]

drakinite

2021-11-04 00:04

developer   ~0065695

Last edited: 2021-11-04 00:05

View 2 revisions

"Title tag" and "Artist tag" have been changed to "Title" and "Artist". It's now been removed from Scripts and added to the addons site: https://www.mediamonkey.com/addons/browse/item/split-featured-artists/

I think that hardcoded examples make more sense in this context, because if a user selects a track that *doesn't* match the pattern, it won't be useful.

There's also a tooltip that wasn't mentioned in this discussion yet: "Enter a comma-separated list of the keyword MediaMonkey should look for to identify featured artists. Useful if the title is in another language. Periods are added automatically."
Since it's currently removed from the built-in scripts, should we keep it as-is?

rusty

2021-11-04 01:41

administrator   ~0065700

I'm having second thoughts. How's this--I would have rathered re-use more strings, but imo it's much clearer:
Title: Split Artists from Title
Description: Move featured artists from Title to the Artist field.
Input label: Keywords identifying artists (comma-separated):
Tooltip: MediaMonkey will use the keywords (as they appear or with a period) to find and move artist names from the Title to the Artist field.

drakinite

2021-11-04 22:26

developer   ~0065729

Done - Updated addon on the site with new text. The description you provided was a bit short, though, and I kept the slightly longer addon description.

rusty

2021-11-05 01:31

administrator   ~0065748

I was actually suggesting the Description text for inclusion within the addon i.e. prior to 'Keywords....'

drakinite

2021-11-05 20:27

developer   ~0065775

Sorry, I see now. Updated now on the site with the new dialog description.

peke

2021-12-18 01:36

developer   ~0066406

verified 2528 and latest addon on site.