View Issue Details

IDProjectCategoryView StatusLast Update
0017818MediaMonkey 5Skinning frameworkpublic2021-05-21 22:20
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0.1 
Target Version5.0.1Fixed in Version5.0.1 
Summary0017818: Custom icon files (for a collection) do not load properly until MM is restarted
DescriptionWhen the user edits a Collection's icon, MM shows a blank icon (though on restart, the icon displays correctly):

1 Edit Collection > Icon Tab > [Choose...]
--> File selector appears
2 Choose an svg file and click 'OK'
--> Edit Collection dialog displays nothing (which indicates to the user that MM doesn't recognize the file)
3 Click OK (which most users wouldn't do since they wouldn't want a blank icon)
--> The Collection's icon changes to ""
4 Restart MM
--> The new icon is applied to the Collection
Additional InformationReported at https://www.mediamonkey.com/forum/viewtopic.php?f=33&t=98956
TagsNo tags attached.
Fixed in build2406

Activities

drakinite

2021-05-18 01:26

developer   ~0063260

This is an issue with the file-loading operation, possibly the app.filesystem.loadSkinFile native method. The file does not load properly when attempting to run loadIcon on the new file when MM is already open. Only after adding a custom icon file to a collection, then restarting MM, does the icon show up and loadIcon (with the custom file) loads the file properly.

Ludek

2021-05-18 19:49

developer   ~0063273

Per IM discussion the custom icons should be copied to user app data folder (where also 'ArtistImages', 'DeviceImages' resides), so subfolder like 'customIcons' might work

Ludek

2021-05-18 21:00

developer   ~0063278

Fixed in 2406

rusty

2021-05-21 22:20

administrator   ~0063384

Verified 2407.