View Issue Details

IDProjectCategoryView StatusLast Update
0017807MediaMonkey 5Burning / Disc Handlingpublic2022-05-25 15:12
ReporterLudek Assigned To 
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.3Fixed in Version5.0.3 
Summary0017807: 'Send to > Audio CD' feature (Burn2MM4 addon)
DescriptionIt seems that many users still burns Audio CDs in these days (per requests at https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98221 )

We could add a simple Send to > Audio CD menu/feature that would show just last page of the 'MM4 Burn Wizard'.
This should be significantly less work than porting whole the "MM4 Burn Wizard" from MM4 (and would be probably enough for MM5 users).
Additional InformationTicket 1322 1443 1479 1949 2725 2976 3279 3406 3428 3470 3471 3561 3568 3639
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=99024
https://www.mediamonkey.com/forum/viewtopic.php?f=33&t=100767
TagsNo tags attached.
Fixed in build2614

Relationships

related to 0016592 closedrusty CD Burning workaround 
related to 0014359 closedrusty Burning: Additional options to burning 
related to 0019038 closedjiri Audio CD Burning functionality 

Activities

Ludek

2021-05-12 13:35

developer   ~0063146

Last edited: 2021-05-12 20:09

A poll was created to find whether 'Send to > Audio CD (burn)' would be desirable: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=99024

rusty

2021-05-31 21:37

administrator   ~0063642

The number of users responding was kind of small, but the feedback was consistent with our intuition that AudioCD burning is more important to users than Data CD burning, but that it is only going to be used by a smallish subset of users.

Ludek

2022-01-20 22:15

developer   ~0066695

image.png (33,441 bytes)   
image.png (33,441 bytes)   
image-2.png (60,770 bytes)   
image-2.png (60,770 bytes)   

Ludek

2022-01-20 22:18

developer   ~0066696

Last edited: 2022-01-20 22:20

I added "Burn CD/DVD using MM4" addon that sents selected files form MM5 to MM4 > Now Playing to be easily burned.

The addon can be downloaded here: https://www.dropbox.com/s/ba23vz2ki08kf3o/burn2MM4.mmip?dl=0
and I also added it to the /sampleScripts/ folder.

Note that the strings are not translated, I think it is OK to be just in English, right?
the used link for "Get MediaMonkey 4" goes to https://www.mediamonkey.com/support/knowledge-base/mediamonkey-general/download-mediamonkey/

Assigned to Rusty to review the addon and publish it as burning workaround.

Ludek

2022-01-21 21:03

developer   ~0066711

Last edited: 2022-01-21 21:07

Improved Burn2MM4 addon (performance + added hotkey), the addon to test is still here: https://www.dropbox.com/s/ba23vz2ki08kf3o/burn2MM4.mmip?dl=0

We might want to add some further instruction (like to not install MM4 on top of MM5) to the configuration dialog that is shown upon the addon installing.

Also, when the MM4 path is no longer found after performing the "Burn CD/DVD using MM4..." action then this dialog is shown:
image-3.png (22,332 bytes)   
image-3.png (22,332 bytes)   

Ludek

2022-01-21 21:26

developer   ~0066712

Also added to "Send to" menu:
image-4.png (24,700 bytes)   
image-4.png (24,700 bytes)   

rusty

2022-04-06 18:32

administrator   ~0067467

Last edited: 2022-04-06 18:36

I agree that this should be an external addon (posted to the addons site), and that it doesn't need to be translated. At the same time, I don't think that this fully addresses the requirement raised by most users (i.e. most users won't have MM4 installed), though it's a decent workaround.

Questions:
a) Is it correct to mention 'DVD's in this addon? I thought it was only for burning audio CDs?
b) When I use the functionality, MM4 opens in the NP view with the selected tracks playing. Is that what's intended? I would have expected that MM4 would open with the burn dialog displaying the tracks (and the tracks not playing).


Suggested changes:
1) The link for MM4 should be to:
http://www.mediamonkey.com/MediaMonkey-4_Setup.exe

2) The default path to MediaMonkey 4 should be changed:
C:\Program Files (x86)\MediaMonkey.exe
-->
C:\Program Files (x86)\MediaMonkey\MediaMonkey.exe

2) String updates:

Burn CD/DVD using MM4...
-->
CD/DVD (burn using MM4)...

Sends selected tracks to MM4 in order to burn them
-->
Sends selected tracks to MediaMonkey 4 in order to burn them

The path to MM4 executable file does not exists:
-->
MediaMonkey 4 cannot be found at:

3) Re. the following functionality, wouldn't it just make sense to change it as follows:

Please install MediaMonkey 4 (click Help to get to the download location) or click OK to browse for the correct path of the MediaMonkey.exe file.
[Help] [OK]
-->
Please configure the addon by installing MediaMonkey 4 (if needed) and configuring the path of the version 4 MediaMonkey.exe file.
[Configure] [OK]

Ludek

2022-04-07 13:22

developer   ~0067482

Re Questions:
a) yes, mention 'DVD' is correct as MM4 can burn DVD
b) opening MM4 with burn dialog displaying the tracks would need to re-release of MM4 as it would require changes in MM4 too

Suggested changes are implemented and the addon updated in /svn/sampleScripts/burn2MM4
I also uploaded it here: https://www.dropbox.com/s/juox7d01c9hiis5/burn2MM4.mmip?dl=0

Assigned to Jordan for adding this addon to our addons repository.

drakinite

2022-04-13 16:17

developer   ~0067526

Updated addon to 1.0.2 to fix issues with the default MM4 path.
Up on the site: https://www.mediamonkey.com/addons/browse/item/burn-using-mediamonkey-4/

drakinite

2022-04-13 16:42

developer   ~0067527

Last edited: 2022-04-13 16:44

Note: Requires MM 5.0.2 or greater. Using Send to -> Burn using MM4 on 5.0.0 or 5.0.1 opens a dialog asking you to save "burn2MM4.m3u" as a file instead of opening MM4. Updated addon metadata on the site to reflect that compatibility requirement.

lowlander

2022-04-29 20:21

developer   ~0067884

Addon works in 2618.

However the amount of users requesting burning from within MediaMonkey 5 warrants further evaluation for 5.1

rusty

2022-04-29 21:27

administrator   ~0067885

Closing, and tracking integrated CD burning at 0019038.