View Issue Details

IDProjectCategoryView StatusLast Update
0017776MediaMonkey 5Main Panelpublic2021-04-29 00:07
Reporterdrakinite Assigned To 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionreopened 
Product Version5.0.1 
Target Version5.0.1Fixed in Version5.0.1 
Summary0017776: Performance issue - Loading a large album in grid view causes entire view to lag, even after it is collapsed
DescriptionBecause all of the listview items are hidden out of view by their position, instead of having display: none, Chromium spends a ton of computation time updating the layer tree because of all those divs being loaded.
TagsNo tags attached.
Fixed in build2400

Relationships

related to 0017783 closedmichal (Regression) Editing items on tracklist sometimes does not display changes 

Activities

drakinite

2021-04-20 18:11

developer   ~0062890

Fixed for 5.0.1 (Also changed "new Date().valueOf()" to "Date.now()" because the latter is marginally faster than the former).

drakinite

2021-04-25 22:20

developer   ~0062914

Changes caused a regression (0017783); temporarily reverted changes until the latter issue can be identified

Ludek

2021-04-26 07:35

developer   ~0062917

Last edited: 2021-04-26 07:36

View 2 revisions

ok, there have been some further regressions that I noticed (and that this revert fixed).

On empty database:
1) Music [Browser view] shown icons for the empty Artists/Albums rows
2) Properties > Classification > Playlists: shows UI artifacts when there is no playlist to which the track belongs

i.e. empty grids/lists were not shown as empty

michal

2021-04-26 18:49

developer   ~0062922

Fixed in build 2400.

drakinite

2021-04-26 19:20

developer   ~0062923

Changes introduced another regression in which the now playing list is not positioned properly when the window initially loads. Fixed in revision 37875

peke

2021-04-29 00:07

developer   ~0062963

Verified 2400

I can't replicate LAG anymore in 2400