View Issue Details

IDProjectCategoryView StatusLast Update
0017769MediaMonkey 5Generalpublic2021-04-16 20:29
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version5.0 
Target Version5.0.1 
Summary0017769: Wine compatibility
DescriptionBuild 2235 fails to launch on WINE (tested by Drakinite with regular and portable buids).

Considering that this worked in MM4 and earlier builds of MM5 (confirmed by Peke), we should try to resolve this if it's not a major issue.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?p=443361#p443361
TagsNo tags attached.
Fixed in build

Activities

drakinite

2021-04-16 20:23

developer   ~0062860

I don't think it's worth focusing our effort on fixing compatibility for WINE. As Ludek confirmed offline, the crashes I experienced were caused by libcef.dll, which is part of Chromium. I even tried installing Chromium on WINE, and it did not display properly.

I believe our focus would be better directed toward getting native cross-platform support, instead of chasing the finicky compatibility layer when we know that Chromium does not play well with WINE.

Ludek

2021-04-16 20:29

developer   ~0062861

Yes, we can't expect that Google's goal is to run windows version of Chromium under WINE