View Issue Details

IDProjectCategoryView StatusLast Update
0017643MediaMonkey 5Tagging / organizing (properties / auto-tools)public2021-03-11 23:13
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017643: Duplicate thm images are added after deleting the last thm
DescriptionIf the user has multiple linked artwork images, then replacing the artwork results in duplicate thm files being added:
1 Select tracks from an album
2 Add n images via Properties > Artwork (i.e. Save image to file folder), and click OK in the Properties dialog to commit the changes
--> folder.jpg, albumname.thm, album
3 re-open Properties > Artwork and delete the images, starting with folder.jpg (and don't commit the changes)
4 add a new image (saved to file folder) and click OK in Properties to commit the changes
--> albumname.thm and albumname_2.thm are created!

Note: for albumname_x.thm that is created, x=n+1

https://www.screencast.com/t/Xjm0ffPcCqDw
TagsNo tags attached.
Fixed in build2323

Relationships

related to 0017640 newmichal Deleting and then adding new artwork cause the new arwork to always be added as .thm 

Activities

michal

2021-03-11 18:48

developer   ~0062390

Fixed in build 2323. Note, that because during saving previous cover files are still present in the folder, as we do not know in advance, that after saving they will not be needed already (issue 0017640), albumname_2.thm is used as new filename (in the mentioned case with two covers).

rusty

2021-03-11 23:13

administrator   ~0062395

Verified that the originally reported issue is fixed in 2323 (the remaining issue (described in Michal's last comment) is tracked at 0017640.