View Issue Details

IDProjectCategoryView StatusLast Update
0017584MediaMonkey 5Generalpublic2021-02-26 19:38
Reporterdrakinite Assigned To 
PriorityurgentSeveritytweakReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017584: Interface performance optimizations
DescriptionTo reduce browser layout recalculations during layout changes:
1) in splitter.js, removed the code that resets sibling minWidth/minHeight
2) moved analyzeSiblings call to the top of mouseDownHandler in splitter.js
3) Instead of changing document.body's class, its cursor style is set directly via JS, in splitter.js and control.js

4) Inside templates_add for Material Design(s) and Metro M, album art colors are cached in memory so that repeatedly-opened albums do not have to recalculate colors.
5) Changed delayedPopup delay from 400ms to 20ms in listview, to make the album grid open/close much faster.

Tracked these changes in case of regressions.
TagsNo tags attached.
Fixed in build2316

Activities

drakinite

2021-02-20 01:18

developer   ~0062038

Fixed for build 2315

michal

2021-02-21 13:25

developer   ~0062067

Added support for GridPopupDelay setting in Options section of MediaMonkey.ini. Default value is 275 (ms).

jiri

2021-02-23 08:58

administrator   ~0062102

Per IM discussion, an addon enabling the delay seems to be a good solution.

Ludek

2021-02-23 11:55

developer   ~0062109

Last edited: 2021-02-23 12:14

View 3 revisions

I don't see the point why anyone would want to install an addon that enables just a delay?
IMHO such an addon will just needlessly occupy our addons repository.

I would rather expect an addon to override the double-click behaviour to start playback (like in MM4) ?

michal

2021-02-23 12:28

developer   ~0062110

Ludek: because for people, who use double-click to go to sub-view, and do not use pop-up much, is worse experience to open popup with every double-click, and it can also affect smoothness of going to sub-view

jiri

2021-02-23 16:46

administrator   ~0062116

And, I suppose that the addon could also evolve, e.g. to let user define double click action as Ludek mentioned.

drakinite

2021-02-23 17:17

developer   ~0062117

Can do :)
Perhaps it can be under Behavioral Tweaks, titled something like "Customize Grid View Behavior"?

rusty

2021-02-24 20:08

administrator   ~0062127

So can this issue be tagged as resolved in 5.0? i.e. the code changes in MM are all complete in 2315 and ready to be tested (the creation of an addon is independent of this) ?

drakinite

2021-02-24 21:06

developer   ~0062128

Last edited: 2021-02-24 21:08

View 2 revisions

I would say so, yes. We can make a new issue to discuss the addon

EDIT: I don't think we came to an agreement on how long the delay should be by default.

rusty

2021-02-25 20:19

administrator   ~0062139

I tested on a current asus core i3 laptop and a 5-year old dell celeron laptop, using mouse, touchpads, and touchscreens. In all cases 175ms seemed to work well, so I'd set that as the default.
Note: 150ms was too fast for the touchpad on one of the laptops (and 0ms, though faster results in flashing of the popup prior to opening the new screen.

A more permanent/future solution could eliminate the performance/UI compromises e.g. current approach of allow links and popups b) allowing only links c) allowing only popups.

michal

2021-02-26 08:01

developer   ~0062154

Fixed in 2316, default delay changed to 175ms. I did not remove possibility of changing this in ini setting, so advanced users like drakinite still can change this. In case you already changed this setting to different value, the new default will not by applied.

rusty

2021-02-26 19:38

administrator   ~0062164

Verified 2316.