View Issue Details

IDProjectCategoryView StatusLast Update
0017582MediaMonkey 5Now Playingpublic2021-03-03 16:53
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityunable to reproduce
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017582: Info panel 'Play' button adds tracks to Playing in an unclear order
DescriptionWhen clicking the 'Play' button that appears in various views, tracks are added in a non-obvious order. e.g. for Artist > ArtistName [Browser], the tracks seem to be added by year, Grouped by Album BUT:

1) The sort order seems to be incorrect. It appears to be something like Year1-Album1, Year2-Album2, Year3-Album3, Year1-Album4, Year2-Album5....

2) The sort order is unrelated to sorts chosen by the user in the view for Albums / Tracklists. It would make more sense if tracks were added to the Playing list based on the sort order of the Elements in the View. This is complicated by the fact that that there can be multiple elements (e.g. Artists, Albums, Tracks) in the view, so perhaps the sort order should be based on an order of preference of the elements displayed. e.g.
a) by Track if it exists, then by Album if it exists, then by Artist if it exists
OR
b) based on the sort order of the first element beneath the info panel
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98462
TagsNo tags attached.
Fixed in build2317

Relationships

related to 0016472 closedLudek Play Now for a node can trigger Playback of tracks different than those that are displayed 
related to 0015937 closedmichal Play/Shuffle buttons in view headers and popups do not respect rule for Play now action 
related to 0014084 closedmichal Add Play Random option on multi file selection ('Play to' option missing) 
related to 0017623 newrusty Info panel PLAY button play order should match the order in the view 

Activities

Ludek

2021-02-19 18:07

developer   ~0062029

Last edited: 2021-02-19 18:13

View 4 revisions

I cannot replicate, if I sort the tracklist by Length and click play button in the 'Info panel' then it is added in the correct order by Length, see: https://www.dropbox.com/s/2pf4oyy4ktl73l6/screenshot%202021-02-19%2019.06.26.png?dl=0
The same goes for Rating and whatever sort order is in the tracklist.

Probably screencast video could show what you are doing differently ?

Ludek

2021-02-19 18:18

developer   ~0062030

Aha, I probably see the reason for the difference, it does not work when "Top Tracks" are shown only. While it works when all tracks are shown. So the solution probably is that in the "Top Tracks" mode it should rather take the albums in the order of "Albums" element (when visible) ?

rusty

2021-02-19 18:30

administrator   ~0062033

Last edited: 2021-02-19 19:20

View 3 revisions

1) I think that if the 'Tracks' element is enabled in a View, and the user presses the Info Panel element's 'Play' button, then MM should play all the tracks associated with the node based on the sort order of the Tracks element that is displayed in the view (regardless of whether 'All tracks' are displayed or just 'Top tracks'), and that in either case, all tracks associated with the node should be played.

2)a) And if the 'Tracks' element is disabled, then use Albums element sort order if it's enabled, and if not, then use Artists element sort order. With this approach the user has can really control play order since they can set sort order granularly (e.g. primary/secondary/tertiary sorts) whenever the Tracks element is enabled. I prefer this approach over 2b below.

2b) Has a bit of a usability advantage since the InfoPanel 'Play' order would be based on the first _visible_ sort (rather than on the 'Tracks' element sort which may be much lower on the screen).

michal

2021-02-22 15:30

developer   ~0062089

But Top Tracks are by default sorted by popularity, which is not assigned for all tracks. It would give strange results. Currently there is no sorting set when pressed play button in this situation (if all tracks are not displayed), I would go with default tracks sorting only, at least for 5.0. I.e. by year, album, order and title.

michal

2021-02-22 17:42

developer   ~0062094

Last edited: 2021-02-25 08:06

View 3 revisions

Suggested default sort order fixed in build 2315. (i.e. when all tracks are not displayed, sorted by year, album, order and title is used)

rusty

2021-02-24 22:40

administrator   ~0062130

Tagging as resolved in 2315 so that it gets tested.

At that time a new bug should be opened to track the remaining post-5.0 issues.

rusty

2021-02-25 22:24

administrator   ~0062142

Last edited: 2021-02-26 13:52

View 2 revisions

Tested 2315 and the sort order for tracks added to Playing isn't by year, album, order and title. I'm not sure what the sort order is. See:
 https://www.screencast.com/t/SIddYmVM8

Reset to 5.0 just for this particular issue.

michal

2021-03-01 10:04

developer   ~0062180

Fixed in build 2317. It was problem in sorting by year.

rusty

2021-03-03 16:53

administrator   ~0062214

Verified 2317, and moved remaining items to 0017623 for future discussion.