View Issue Details

IDProjectCategoryView StatusLast Update
0017572MediaMonkey 5Main Panelpublic2021-02-20 20:51
Reporterdrakinite Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017572: Performance issue - Layout thrashing when switching between tabs
DescriptionThe interface currently stutters very badly when switching tabs. Performance analysis reveals many notifyLayoutChangeDown calls and a lot of time is wasted recalculating layout on multiple occasions. It might be possible to find a simple solution like in 0017118, but if not, it should probably be looked into for 5.0.1.

Chromium Performance recording export: https://1drv.ms/u/s!AqHzUrf30uprpf1bB3t5czOfO8rJAg
TagsNo tags attached.
Fixed in build2314

Relationships

related to 0017118 closedpetr Performance issue - Extreme layout thrashing when tooltips fade in and out 

Activities

Ludek

2021-02-18 16:09

developer   ~0061990

Fixed in 2313

rusty

2021-02-19 02:48

administrator   ~0062016

Verified 2313.

Ludek

2021-02-19 19:33

developer   ~0062036

Re-opened the issue based on offline discussion with Draki, it still happens with some specific tabs configurations.

Ludek

2021-02-19 20:53

developer   ~0062037

Last edited: 2021-02-19 22:06

View 2 revisions

Significantly improved in 2314

drakinite

2021-02-20 20:51

developer   ~0062050

Confirmed for 2314; I want to wait until 2315 before closing, though, since there were some extra related code changes that aren't a part of 2314.