View Issue Details

IDProjectCategoryView StatusLast Update
0017366MediaMonkey for AndroidSynchronizationpublic2021-04-12 19:20
Reporterpeke Assigned To 
PriorityimmediateSeveritymajorReproducibilityunable to reproduce
Status closedResolutionfixed 
Target Version1.4.4Fixed in Version1.4.4 
Summary0017366: Background tasks never finish
DescriptionBased on user description after updating to Android 11 MMA never finish syncing and background tasks.

Additionally it also sync files that should not be resynced and updated.

I am unable to reproduce on my devices.

User supplied Logs according to:
1. Before you start Sync = E9ZAQWR4V3
2. After Sync = 52AKIB8TP8
3. Wait some time ~2m and if circle do not disappear send it again = LD31CCLF6T

Note user is using WiFi Sync
Additional Information[Ticket #502] OS11 / OneUI 3
TagsNo tags attached.
Fixed in build951

Relationships

related to 0017565 closedmartin Sync settings default: disable 'update playlists from other apps' 
related to 0017744 closedmartin Crash onclearing Now Playing and associated playlists 

Activities

martin

2021-03-10 17:33

developer   ~0062352

The first part of the issue is fixed by 0017565

The second part is related to big playlists.
Another user in https://www.mediamonkey.com/forum/viewtopic.php?f=21&t=98578

Examples of two playlists "Small" and "Big"
1)Use wifi sync to sync "Small" Playlist with few tracks
2)Sync is successful
3)Start sync with Android Media Store automatically
4)MMA found Remote "Small" Playlist, check number of tracks,
if playlists are the same, playlists are paired IMMEDIATELY.


Step to reproduce:
1)Use wifi sync to sync "Big "Playlist with e.g 25k
2)Sync is successful
3)Start sync with Android Media Store automatically
4)MMA found Remote "Big" Playlist,
but the playlist is empty. Delete the remote playlist.
The local playlist will be inserted into "Android Media Store" by MMA
- IT TAKES A LOT OF TIME FOR big playlists - to improve it we can check the playlist timestamp and when the playlist is new then we can postpone pairing (the playlist will be loaded on the System side
and MMA will pair it only).

martin

2021-03-10 21:20

developer   ~0062359

Fixed in build 1.4.3.949

peke

2021-03-11 19:42

developer   ~0062393

Verified 949

User is notified and should be closed on confirmation.

martin

2021-03-15 15:31

developer   ~0062455

Last edited: 2021-03-15 15:32

View 2 revisions

MMA syncs playlists to the Android media library(AML).
Simplified cases when it happens are:

LOCAL ONLY - (Playlists are only in MMA)
1)Playlist was created on MMA side
2)Playlist was sync from MMW(improved in previous build)
3)Playlist is only in MMA and does not exist in AML

REMOTE ONLY
4)Remote Playlist(from AML) was found in MMA, but has a different count of items

IN BOTH
5) but a remote playlist is unsupported(does not have file)
6) local is modified and remote not


IF MMA syncs playlist from MMW/MM5, then MMA creates "m3u" file, which is scanned by Android and insert into AML automatically.
 
So in my opinion it's not necessary to sync all playlist items to AML on MMA side in case 'update playlists from other apps' is disabled.
We can disable syncing playlists to AML because we don't need updated AML immediately because AML updates itself.

This will solve the issue with a never-ending Background task (syncing big playlists to AML).

I will test it on different Android versions and I would include it in the next build.

martin

2021-04-12 15:11

developer   ~0062786

Fixed in build 1.4.4.951

peke

2021-04-12 19:20

developer   ~0062793

Verified 951

Unable to replicate