View Issue Details

IDProjectCategoryView StatusLast Update
0017291MediaMonkey 5Generalpublic2021-01-18 21:51
Reporterdrakinite Assigned To 
PriorityimmediateSeveritycrashReproducibilityrandom
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017291: Problems with app restart/reload
DescriptionSince 0017168, several issues with app restart have occurred. But most are random, and not very consistent:

1) Sometimes app reload closes all instances of MediaMonkey, including MM4 and other builds/installations of MM5 that are open
2) Sometimes the background process does not actually close, so when it reopens, you get an error saying the sharing port is already being used by another process
3) Occasional crashes (see logs with ID 40DFB906)
  3a) When the crashes occur, it's constant, and you have to force-close the processes to make the crashes stop
4) App restart, open and close almost always takes a VERY long time, and the window often constantly steals focus during the long restarts

* It would be preferable if there can be a new reload method which only reloads the window (HTML+JS+LESS), to be be used when changing skins and by RefreshSkinShortcut. *
Steps To ReproduceIssues are more reproducible when you have MM4 also open, then use RefreshSkinShortcut to perform a full reload.
TagsNo tags attached.
Fixed in build2294

Relationships

related to 0017168 closedpetr Localization: freeze and loss of language options upon selecting a previously installed language 
related to 0017403 closedLudek Install as service not working in some specific environments 

Activities

drakinite

2020-12-26 22:14

developer   ~0061079

Two debug logs. First is a successful reload without issues, when MM4 was in the background. I cleared the log then performed a reload a second time, then it forceclosed MM4 and opened with port in use as well as a crash.

petr

2020-12-27 23:05

developer   ~0061099

Improved reload batch

drakinite

2020-12-29 21:58

developer   ~0061118

Items 1 and 4 appear to be resolved, but items 2 and 3 are still present.

See logs with ID 40DF6157 and 40DFB906; I believe they are caused by the background MM process that was not properly terminated during the restart.

Ludek

2020-12-30 12:29

developer   ~0061123

Last edited: 2020-12-30 12:35

View 2 revisions

Some problems with the restart batch discussed offline with Petr.

Another report of crash during restarting (after skin change) reported here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=98026
Crash 40DF6157

petr

2020-12-30 19:16

developer   ~0061129

Fixed

peke

2021-01-08 00:10

developer   ~0061207

Reopen MM5 now closes but do not restart it stays closed.

peke

2021-01-08 00:14

developer   ~0061208

Last edited: 2021-01-08 20:57

View 3 revisions

Log was started just before I changed Skin from MetroM classic to MonkeyGroove.
bug17291.rar (12,148 bytes)

petr

2021-01-12 21:20

developer   ~0061302

Fixed

peke

2021-01-15 00:33

developer   ~0061353

Verified 2295

Looks like we finally got it. Made changes works like a charm.