View Issue Details

IDProjectCategoryView StatusLast Update
0017168MediaMonkey 5Install/Configpublic2020-12-30 12:32
Reporterrusty Assigned To 
PriorityimmediateSeveritycrashReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017168: Localization: freeze and loss of language options upon selecting a previously installed language
DescriptionIf the user switches to a language that was used to install MediaMonkey, MediaMonkey freezes.

1 Double click installer and choose French
2 Do a clean Portable install
3 Run MM and go through the wizard leaving the defaults
4 Switch to English via Tools > Options > Language, and allow MM to restart
--> MM is now in English
5 Switch to French via Tools > Options > Language
--> MM Freezes (white screen)!
6 Force close MM with process explorer
7 Run MM
--> MM is running in French
8 Go to Tools > Options > Language
--> 'English' appears as the active language, and French is no longer in the list of languages (which means it's impossible to switch to English!
9 Switch to German and allow MM to restart
10 Go to Tools > Options > Language
--> French is still not in the list of languages--there's no way to switch back to French!

Note: the above occurs consistently. I've only tested with MediaMonkey Portable.
TagsNo tags attached.
Fixed in build2286

Relationships

related to 0017165 closedpetr Crash after reloading window when device sync preferences have been changed 
related to 0017230 closedpetr MediaMonkey takes 25s to close (regression 2286) 
related to 0017238 closeddrakinite Regression - Window reload now stops music playback 
related to 0017277 closedLudek Run of build 2289 --> crash! (regression) 
related to 0017291 closedpetr Problems with app restart/reload 

Activities

petr

2020-12-07 20:33

developer   ~0060615

I'm unable to reproduce this issue and there were many changes in this area ... so please retest and feel free to reopen when you'll be able to reproduce.

rusty

2020-12-08 15:39

administrator   ~0060621

User report of this at: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=97877 in 2281

I'm still able to replicate this as well in the manner that I'd originally described.

petr

2020-12-08 19:33

developer   ~0060626

Fixed

peke

2020-12-12 16:15

developer   ~0060724

Verified 2283

Unable to replicate in this version. @Rusty please confirm and close

rusty

2020-12-13 00:43

administrator   ~0060746

Last edited: 2020-12-13 00:56

View 4 revisions

I'm not sure if I'm seeing the same bug or a different one (possibly related to the Welcome screen), but when I perform a similar but even simpler set of steps with 2283, MM's skinning breaks and MM subsequently crashes (the original set of steps also triggers the crash).

1 Double click installer and choose English
2 Do a clean Portable install
3 Run MM and go through the wizard leaving the defaults
--> Welcome screen appears
4 Switch to French via Tools > Options > Language, and allow MM to restart
--> MM is now in French, welcome screen no longer displayed
5 Click Tools > Options
--> Skinning is broken (everything appears in shades of grey)!
6 Switch to English via Tools > Options > Language and allow MM to restart
--> MM crashes (white screen) - crashlog A2804DF9
MM must be force-closed

https://www.screencast.com/t/u64RnzyErCXz

If on the other hand, the above steps are performed but step 3a is added in which the user clicks the 'Music' node (i.e. leaves the welcome screen) and proceeds with the remaining steps
--> the skinning problem still occurs and the crashlog isn't generated but MM white screens and fails to terminate.

An even simpler case of instability occurs if step 4a is added in which the user tries to close MM (after switching the language)
--> MM fails to close
See: https://www.screencast.com/t/nrS4CjeU

Summary: I'm not sure if this is the same issue as originally reported, but it seems much worse since _any_ change in language post-install often results in instability/crashes (as per the simplest case in which step 4a is taken). I've tested this on two different laptops.

petr

2020-12-14 08:51

developer   ~0060756

Skinning problem is fixed.

rusty

2020-12-14 19:48

administrator   ~0060770

Last edited: 2020-12-14 19:56

View 2 revisions

Tested 2284. Skinning issues are resolved, however, switching skins still resolves in a crash when the user attempts to close MM.
Crashlog 63E64969.

Here's the simplest set of tests that trigger a crash:
1 Install MM5 portable - English and run
2 Go through the wizard defaults
3 Switch to french
--> MM restarts
4 Close MM
--> crashlog 875B4256 (MM must be force-terminated)

petr

2020-12-14 20:39

developer   ~0060778

Fixed

rusty

2020-12-14 22:07

administrator   ~0060779

Last edited: 2020-12-14 22:46

View 3 revisions

Tested 2285 and there are no longer any crashes with the repro steps below, however, MediaMonkey still fails to terminate. i.e.
1 Install MM5 portable - English and run
2 Go through the wizard defaults
3 Switch to french
--> MM restarts (but the Welcome screen doesn't display)
4 Close MM
--> 2 additional instances of MediaMonkeyEngine.exe appear in the processExplorer and MM fails to terminate

This is shown in the video: https://www.screencast.com/t/qaYSvWde

A few points worth noting that may be related to the cause:
1) In contrast to the test case above, if I force terminate and restart MM, the welcome screen _does_ appear (whereas, as shown in the video above, re-loading MM causes the screen to not appear. Petr indicated that this issue also occurs with Web/Last.fm).
2) When I close MM normally, there are only 2 instances of MediaMonkeyEngine.exe (whereas in the video above, 4 instances appear when closing MM after re-loading).
3) The issue does not occur with another addon such as the codec pack i.e.
i.e.
1 Clean install MM5 portable - English and run
2 Go through the wizard defaults
3 Add the MM Codec Pack - Trial
4 Restart on prompt
--> On restart
The welcome screen appears
MM closes correctly (no extra MediaMonkeyEngine instances).

rusty

2020-12-15 07:17

administrator   ~0060784

After much testing, I still haven't found the trigger which causes this issue to occur. The good news is that it doesn't seem to be occurring as often in build 2285. What I have found is that:
- Running MM and closing it --> MM closes in 5s
- Running MM and Switching languages and closing it --> MM closes in 2m
- Running MM and triggering the bug --> MM fails to close and must be force closed
- Running MM after it has been force closed and closing it --> MM closes in 1m (even when the language hasn't changed)--i.e. the bug or the act of force closing MM causes some kind of issue with closing.

Here are the various tests I'd performed (associated debug logs are on the ftp server). The ones that will probably be most useful to you are case 4, case 5, and case 7:
Case 1:
1 Install English
2 Wizard
3 Switch to french
--> welcome screen doesn't show
4 Close
--> 2 MediaMonkeyEngine exes appear
--> closes after 2 minutes

Case 2:
5 Run MM
--> french UI, welcome screen shows
6 Switch to English
--> Welcome screen doesn't show
7 Close
--> 2 MediaMonkeyEngine exes appear
--> closes after 2 minutes

Case 3:
8 Run MM
--> English UI, welcome screen shows
9 Close MM
--> Closes within 5 seconds

Case 4:
10 Run MM
--> English UI, welcome screen shows
11 Switch to Spanish (Chile)
--> didn't notice whether welcome screen showed
12 Switch to French
--> welcome screen shows!
13 Close MM
--> MM fails to close for 10 minutes (had to force close)

Case 5:
14 Run MM
--> English UI, welcome screen shows
15 Close MM
--> Closes within about 60 seconds (consistently)! -- unclear why this is different than case 3; perhaps case 4 somehow corrupted settings? Note: I saved the /Portable directory from this test.

Round B - No welcome node
--------------------------------------------------
Case 1:
1 Install English
2 Wizard
3 Switch to the Music node (i.e. away from the welcome node) and then switch to French
4 Close
--> Six MediaMonkeyEngine exes appear!!!
--> closes after 2 minutes

Case 2:
5 Run MM
--> french UI
6 Switch to English
7 Close
--> extra MediaMonkeyEngine exes appear (didn't see how many)
--> closes after 4 minutes

Case 3:
8 Run MM
--> English UI
9 Close MM
--> Closes within 5 seconds

Case 4:
10 Run MM
--> English UI
11 Switch to Spanish (Chile)
12 Switch to French
13 Close MM
--> I noticed about 8 instances of MediaMonkeyEngine.exe
--> MM closes in 3 minutes -- the only reason I can think of why this is different that case 4 is that perhaps sometimes switching between more languages causes some sort of corruption in settings but not always. OR the welcome screen somehow results in worse problems?

Case 5:
14 Run MM
--> French UI
15 Close MM
--> Closes within about 5 seconds (consistently)! -- the only reason I can think of why this is different that case 4 is that perhaps sometimes switching between more languages causes some sort of corruption in settings but not always.

Case 6:
= same as B4, but switching between 5 languages before closing
--> Closes within 2 minutes

---------------------------------------------
Round C:

Case 7:
1 Fresh English install
2 Switch to 3 different languages
3 Switch back to English
4 Close MM
--> Failure to terminate! -- Could it be that switching back to English triggers the problem? (Note: this could be because the Welcome screen only appears for the language for which MM was run)

Case 7b:
5 Start MM
6 Close MM
--> Takes about 60s to close (just like with case 5). i.e. it seems that once a failure to terminate occurs ?something? changes causing MM to consistently close more slowly!!

Ludek

2020-12-15 12:57

developer   ~0060786

Last edited: 2020-12-15 13:02

View 2 revisions

I can consistently replicate the issue too, so far I found that:
1) the issue happens also after skin change (or also after any addon install/unistall)
2) the issue does not happen when d_WMDM.dll is removed

petr

2020-12-15 17:23

developer   ~0060790

Fixed

Ludek

2020-12-15 20:20

developer   ~0060796

Last edited: 2020-12-15 20:20

View 2 revisions

Re-opened, the issue still occurs after the skin change, details discussed over IM

Ludek

2020-12-15 21:56

developer   ~0060797

Works fine for me finally in 2286.

rusty

2020-12-15 22:39

administrator   ~0060798

Last edited: 2020-12-25 16:45

View 2 revisions

Verified 2286, however, there's a new performance issue: MM now always takes 25s to close (previous builds would take 5s to close). I'll track this in a separate issue.

EDIT by Ludek: Tracked as 0017230