View Issue Details

IDProjectCategoryView StatusLast Update
0017209MediaMonkey 5UPnP / DLNApublic2021-01-18 17:35
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0017209: UAC prompt is shown after every re-install (also in Portable mode)
DescriptionWhile implementing #17005 I found that UAC prompt is shown after every re-install.

This happens because of 0013261 where MM is re-creating the firewall rules after every install per suggestions in the note 0013261:0045392
Per 0015176 the firewall rules are re-created also for Portable version (on MM server run)

So it is expected case according to 0013261 / 0015176 / 0017139

But with the amount of updates of MM5 the UAC prompt is quite bothering and especially on Portable install the user might not have the permission to even accept the prompt.
So I would rather disable this prompt on every update for the Portable version.

And as the cause (Win10 anniversarry update 0013261:0045392 ) might be no longer an issue (because users mostly already updated to that Win10 version) -- then we could consider removing the UAC prompt also for standard install.
TagsNo tags attached.
Fixed in build2282

Relationships

related to 0013261 resolvedLudek MediaMonkey (current) MediaServer: Some Components are still blocked by firewall 
related to 0015176 closedLudek MediaMonkey 5 Playing from portable version to a renderer may fail (as portable version doesn't auto-conf firewall) 
related to 0017139 closedLudek MediaMonkey 5 UAC Dialog Shows even on MM5 portable if MM5 is used alongside with MM4 
related to 0017402 newpetr MediaMonkey 5 Portable mode: should not automatically make system changes 

Activities

Ludek

2020-12-10 13:39

developer   ~0060681

Removed for Portable version in 2282

peke

2020-12-13 04:11

developer   ~0060750

Verified 2283

No prompts for Portable installs.