View Issue Details

IDProjectCategoryView StatusLast Update
0017180MediaMonkey 5Tagging framework / input pluginspublic2022-10-19 17:51
Reportermichal Assigned To 
PriorityurgentSeveritycrashReproducibilitysometimes
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0.4Fixed in Version5.0.4 
Summary0017180: Tagging MP3 10s before the end leads to playback loop
DescriptionTagging MP3 near the end of the file, circa 10s before the end, causes jump of seek bar circa 10s back and then looping of the last 10s of the file. For the user endlessly, for me the last part is played twice.
Reproduced with both, WASAPI and MMDS.
Additional InformationTicket #306
TagsNo tags attached.
Fixed in build2660

Relationships

related to 0015913 closedmichal MediaMonkey 4 Playback: MM Player skips to next if playback set on seek bar in <10 seconds from end 
has duplicate 0016992 closedmichal MediaMonkey 5 Playback Loops, can't be Paused/Stopped/Next 
related to 0017266 closedmichal MediaMonkey 5 Change tags on large number of tracks --> crash 
related to 0017505 closedmichal MediaMonkey 5 Playback stutters when a large number of tracks change rating (WASAPI only?) 
related to 0019335 closedmichal MediaMonkey 5 Playback sometimes continues after pressing pause 
related to 0019383 closedLudek MediaMonkey 5 Edits to read-only tracks appear to succeed if the track is playing (regression 2660) 

Activities

michal

2020-12-16 18:39

developer   ~0060818

This problem is the same for MM4, pushing to 5.0.1, as it is hard to fix and the fix will be always risky.

Ludek

2022-07-21 12:34

developer   ~0068867

Something similar reported here: https://www.mediamonkey.com/forum/viewtopic.php?p=499032#p499032
so looks like the same issue?

michal

2022-08-11 07:22

developer   ~0068999

Fixed in build 2660. Playing file is now tagged after finishing playback.

peke

2022-08-19 21:25

developer   ~0069035

Last edited: 2022-08-19 21:25

Verified 2660

I was not able to replicate constant loop, but in my case it just simply stutter and continue on 2659.