View Issue Details

IDProjectCategoryView StatusLast Update
0016929MediaMonkey (current)DLNA/UPnPpublic2020-10-22 23:41
Reporterlowlander Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.1 
Target Version4.1.31Fixed in Version4.1.31 
Summary0016929: UPNP Search shows empty results for Albums and Artists
DescriptionWhen doing an UPnP Search of the MM5 Media Server there are no results shown when selecting to view Albums or Artists. Tracks does show results , but can fail to show results in a timely fashion when switching between Albums, Artists and Tracks.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=26&t=97356
TagsNo tags attached.
Fixed in build1915

Relationships

related to 0016584 closedLudek MediaMonkey (current) UPnP Search: UPnP search do not return correct results 
related to 0017024 closedLudek MediaMonkey 5 UPNP Search shows empty results for Albums and Artists 

Activities

peke

2020-09-30 21:29

developer   ~0059738

I can't replicate, but it is interesting that if I click on search icon whe Albums/Artist are selected results are shown almost immediately.

peke

2020-10-04 02:06

developer   ~0059752

I hope that MMW debug log is usable, I also noticed that he uses TP-Link USB Adapter on PC so Double WiFi connection if used on same router can create bottleneck and slow don search.

martin

2020-10-21 09:46

developer   ~0059926

1) PERFORMANCE
9R5I4HTRY3 - I can see that
Request: id:0,filter:*,search:(upnp:class = "object.container.album.musicAlbum") and (dc:title contains "Elton John" or dc:creator contains "Elton John" or upnp:artist contains "Elton John" or upnp:genre contains "Elton John" ), Items: 0-20
Response: <DIDL-Lite xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:sec="http://www.sec.co.kr/dlna/" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/" xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/"></DIDL-Lite>
It means no items returned from MMW.
If there should be some albums appear, maybe be user should provide MMW database to analyze for Ludek.

J8588XJ299
Request: id:0,filter:*,search:(upnp:class = "object.container.person.musicArtist") and (dc:title contains "Elton John" or upnp:genre contains "Elton John" ), Items: 0-20
(Timeout of 19 seconds while waiting for HTTP request) Connection error or no response received
It means that
a) Connection issues or b) Processing of result takes too much time on MMW side.

2) UI
From my testing
MMA has an issue in Tab views to show (LOADING/NO_ITEMS)state correctly. So a user doesn't know whether MMA is still loading or a result is empty.
It's caused by tabs, which cover the "empty/loading" view.
This UI issue is already fixed in MMA 2.0.
In MMA 1.4.x tabs are implemented in the old way and it will take some time to solve this issue.
So I can try to fix it also to 1.4.2, but I would like to postpone further testing to version 2.0.X, which should be tested in all ways and we can implement required improvements immediately.

martin

2020-10-21 10:52

developer   ~0059927

Re 2)
UI Fixed in build 1.4.2.939

peke

2020-10-22 07:58

developer   ~0059940

Last edited: 2020-10-22 08:18

View 2 revisions

No all collections are selected.

I have made setup on my PC and was able to replicate bug Even MMA ended in failed connection.

Full MMW Log File uploaded on FTP.
bug16929.png (37,204 bytes)   
bug16929.png (37,204 bytes)   

peke

2020-10-22 08:18

developer   ~0059941

bug16929 MMA.jpg (207,963 bytes)   
bug16929 MMA.jpg (207,963 bytes)   

Ludek

2020-10-22 19:30

developer   ~0059947

Last edited: 2020-10-22 21:09

View 3 revisions

Fixed in 4.1.31.1915 and merged to 5.0.0.2271 as 0017024

The issue really was that MM4/MM5 was not searching the default 'Music' collection for the album/artist items, but the 'Recently Added' custom collection instead -- this also confirms the user's workaround of changing the value of 'recently added' to a ridiculously large 1500 (days)