View Issue Details

IDProjectCategoryView StatusLast Update
0016851MediaMonkey 5Playlists (Auto) / Search / Filterspublic2020-08-13 19:47
Reporterlowlander Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016851: Inline edit of Playlist name in Tree adds leading space
DescriptionWhen creating a new Playlist and editing the name it's added with a leading space, which means it shows first in the Media Tree. This leading space isn't in the Playlist name when editing the Playlist or in the Playlist popup window, it can only be accessed through the Media Tree when editing the name there.
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=97042
TagsNo tags attached.
Fixed in build2263

Relationships

related to 0016261 closedpetr Playlists: New Playlists should be first in tree till refresh / focus issue with prompt for playlist name at top of List 
related to 0016631 assignedLudek Add option to trim leading/ending space character from metadata like ignore THE option 

Activities

peke

2020-07-26 18:43

developer   ~0059126

I am Unable to replicate that, can you make video or give more steps how to replicate?

michal

2020-07-27 10:44

developer   ~0059141

Last edited: 2020-07-27 11:44

View 2 revisions

I can reproduce it by by adding new playlist "Test playlist", then clicking F2 in Media Tree on node - Playlists - Test playlist, it fills editbox with " Test playlist", but correct title seen elsewhere is "Test playlist".

michal

2020-07-27 12:03

developer   ~0059144

Fixed in build 2262. New playlists were really created with leading space, so already created playlist names have to be fixed manually by F2 in Media tree and removing the leading space. Newly created playlists should be already created without this space.

peke

2020-07-31 00:42

developer   ~0059185

Verified 2262

@michal thx I was able to replicate steps from 0016851:0059141 in 2261 and confirm that it is not happening in 2262

Ludek

2020-08-03 12:51

developer   ~0059212

Last edited: 2020-08-03 14:32

View 5 revisions

Re-opened:
The issue rather is that for the playlists created with leading space (like ' - New Playlist - ' to be on top of the list) the leading space is shown only when editing in media tree or using F2 edit, but the space is not shown when editing via 'Info Panel' or via 'Playlist Editor'. The leading space is hidden and cannot be even deleted (until is edited via media tree).

i.e. when user created a new playlist and renamed it to 'My Playlist' via the 'Playlist panel' then the playlist name actually was ' My Playlist' (with leading space)

So the issue is still reproducible in 2262 using these steps:
1) create new auto playlist
2) It is shown with editable name in playlist header (Info Panel)
3) press z key three times to rename it from '- New Auto-Playlist -' to 'zzz'
=> Playlist is shown as 'zzz', but using F2 edit in media tree will show that its name is actually ' zzz' appearing before 'Accessible Tracks' !!

Fixed in 2263

peke

2020-08-03 18:22

developer   ~0059219

Just wonder If It would be better instead of '-' we use '!' as it will alert user to Rename playlist?

Ludek

2020-08-03 19:49

developer   ~0059221

I don't think that '!' is better than '-'

peke

2020-08-13 02:54

developer   ~0059374

Verified 2263

Unable to replicate.

rusty

2020-08-13 19:47

administrator   ~0059393

Closing (I agree with Ludek re. the formatting of new playlists with '-' in the name).