View Issue Details

IDProjectCategoryView StatusLast Update
0016261MediaMonkey 5Playlistspublic2020-04-07 15:54
Reporterpeke 
PriorityurgentSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016261: Playlists: New Playlists should be first in tree till refresh / focus issue with prompt for playlist name at top of List
DescriptionDuring testing #12355 it functions correctly, but there are some tweaks we should consider:

I) New Playlist as it is not focused it is put in play on tree making it difficult to locate when having large number of Playlists and user needs to scroll to be able to D&D tracks to it (there is no benefit of #12355 implementation). SOLUTION: Put Newly created playlist Top Of root playlist till view is refreshed (eg. tree collapsed/expanded) as that way user can easily find them and use D&D as explained in #12355

II) new playlist name is always "New Playlist" and user needs to loose focus in order to Rename it, as it is not focused and when (1.) gets fixed it should Auto Init Rename of newly created playlist so that user do not end up with multiple "New Playlist" entries in tree.

NOTE this do not affect Auto Playlist as they are Focused on creation, maybe we can also consider Auto Init of edit playlist name on creation so that user needs to confirm it (with Enter Key)
Steps To ReproduceI) Steps:
   1. Expand Playlist tree node
   2. Right click -> New Playlist
   3. Right click -> New Playlist
   4. Right click -> New Playlist
   5. Right click -> New Playlist
   6. User ends with multiple playlists names "New Playlist"
TagsNo tags attached.
Fixed in build2236

Relationships

related to 0016217 closedLudek Copy/Paste/Move Playlist --> tree nodes get mixed up 

Activities

Ludek

2020-01-17 10:06

developer   ~0055943

Last edited: 2020-01-17 10:31

View 9 revisions

ok, I have made the "New Playlist" being the first in the list (until it is renamed)
=> Fixed in 2221

But as for the issue described by you, most of them I cannot replicate,
in my case when I right-click Playlists node : New Playlist
=> playlist panel is opened and _New Playlist_ is in the title edit mode to change the playlist name immediately, see the screenshot.

If I don't touch the playlist (not changing the name or add a new tracks) then the playlist is automatically deleted.

So tried to use your steps:
   1. Expand Playlist tree node
   2. Right click -> New Playlist
   3. Right click -> New Playlist
   4. Right click -> New Playlist
   5. Right click -> New Playlist
=> I still see just single "New Playlist" node as all the others have been auto-deleted meanwhile.

So from my perspective there is no change required.



playlist.png (9,189 bytes)
playlist.png (9,189 bytes)

peke

2020-01-17 16:35

developer   ~0055970

Reopened
I) Playlist is not always created first in case of creating Sub Playlist and there is lots of Playlist like in case of Imported Playlists Will upload video showing it. NOTE I can't replicate Multiple creations in 2221

II) For me it do not open in EDIT mode It is just created

rusty

2020-01-20 19:52

administrator   ~0056043

Last edited: 2020-01-20 19:59

View 3 revisions

From what I see, this may be another case of 0016217.

It can be replicated consistently as follows:

Case:
Playlists
 - Playlist 1
 - Playlist 2
...

1 Right click 'Playlists', select 'New Playlist'
--> 'New Playlist' node appears (lets call this NP1) right below 'Playlists' node
2 Right click on the 'Playlist 1' node, select 'New Playlist'
--> NP1 disappears and a new 'New Playlist' node appears as a child of 'Playlist 1'

Furthermore, once this bug occurs, it seems that all subsequently created New Playlists don't appear with an editable name in the Playlist Editor!

Raising priority to urgent.

EDIT: Another possibility is that the playlists aren't being saved because the user isn't making any edits to them. But if that's the case, then they should never have appeared in the tree in the first place.

Ludek

2020-01-21 20:34

developer   ~0056093

Last edited: 2020-01-21 20:46

View 3 revisions

Fixed in 2222

Re: Rusty's EDIT: Yes, if the playlist isn't saved then it is auto-removed per item 2a in #13530
But now with the new playlist being always as first we can revert #13530 / 2a (reverted in 2222)

peke

2020-01-26 01:36

developer   ~0056223

Verified 2223

For me it works much better, user friendly and logical now.

@Rusty Please close after test

rusty

2020-01-26 21:42

administrator   ~0056241

Verified 2223.

rusty

2020-03-20 20:16

administrator   ~0057252

Issue II) is recurring in build 2233. i.e. even though a newly-created Playlist appears to have 'New Playlist' (the playlist name) in focus, typing has no effect and the user must manually click on the playlist name to edit it.

https://www.screencast.com/t/MhRQyTXY

rusty

2020-03-20 20:16

administrator  

bug16261_build2233.7z (84,640 bytes)

Ludek

2020-03-21 18:15

developer   ~0057268

Last edited: 2020-03-21 18:36

View 3 revisions

I can confirm it, this seems a general bug in cascade menus where whole main window loses focus after using cascade menus !
e.g. right-click a track > Send to > Pin it
=> focus is not returned back to the main window, can be verified by pressing Alt to focus main menu => nothing happens

The issues does not appear for standard menus, but only for cascade menus.
Assigned to Petr as it is window management issue.

petr

2020-03-25 18:29

developer   ~0057346

Fixed

Ludek

2020-03-25 18:31

developer   ~0057347

Note that this was already fixed in 2234 by the same fix as 0016445

peke

2020-03-25 19:14

developer   ~0057349

Verified 2234

As Pointed by Ludek it looks fixed by 0016261:0057268

rusty

2020-03-27 16:33

administrator   ~0057383

This is still occurring for me in 2235:
https://www.screencast.com/t/xozEkC933

Debug log attached below.

rusty

2020-03-27 16:34

administrator  

New Playlist renaming focus issue.7z (100,098 bytes)

petr

2020-03-27 19:39

developer   ~0057387

Fixed

rusty

2020-03-27 22:22

administrator   ~0057390

Still occurring in 2236 :-(

rusty

2020-03-27 22:27

administrator   ~0057391

It actually seems to be working almost all of the time, and just happened to fail on one occasion. So I'm re-resolving and will open it if I can replicate/log the issue.

rusty

2020-04-07 15:54

administrator   ~0057514

Verified 2239.