View Issue Details

IDProjectCategoryView StatusLast Update
0016580MediaMonkey 5UPnP / DLNApublic2020-05-22 18:32
Reporterpeke Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Target Version5.0Fixed in Version5.0 
Summary0016580: DLNA: MM5 sometimes fails to see some DLNA Servers
DescriptionThere is two current issues:

1. No button to manually refresh Server list in case Server is not seen, MM5 restart needed to be restarted to show it (PavlePC.7z)

2. In some cases MM5 server is not found even after restart. Note that other Servers are seen on same PC (sicinlaptop.rar)

Log files from both PCs and Devices and services image is uploaded to FTP
Steps To ReproduceThese are steps done on both PCs:

1. Start MM5
2. Went to devices and services
3. Start MM5 on other PC
4. wait till Servers are found (SICINLAPTOP missing even after 20 Min waiting)
5. Restart MM5 on PAVLEPC
6. Check if new servers are found (SICINLAPTOP is now shown on PavlePC, but PAVLEPC is not seen on SOCINLAPTOP)
7. Restart MM5 on SICINLAPTOP
8. Only WMP is seen on SICINLAPTOP
9. Save Both LOG files

For Availability test of PAVLEPC Tried sync from Phone to PAVLE PC -> Works (not in logs)
TagsNo tags attached.
Fixed in build2251

Relationships

related to 0013261 resolvedLudek MediaMonkey (current) MediaServer: Some Components are still blocked by firewall 
related to 0015541 feedbackpeke MediaMonkey 5 MMS: MM5 do not see MMS on QNAP 
related to 0015176 closedLudek MediaMonkey 5 Playing from portable version to a renderer may fail (as portable version doesn't auto-conf firewall) 

Activities

Ludek

2020-05-07 12:53

developer   ~0057887

1) the button shouldn't be needed as in MM5 the server list is refreshed automatically.
i.e. whenever a new server is started then it automatically appears in the 'Devices & Services > Media Serviers' section.
Just seeng that media tree nodes are not refreshed this way. TBD

peke

2020-05-08 02:21

developer   ~0057906

1) This is not happening in My tests difference from those two PCs is that PAVLEPC is Wired and have Static IP address, but even changing Static Ip it is still not seen on SICINLAPTOP.

peke

2020-05-08 19:24

developer  

bug16580 Firewall issue.jpg (106,837 bytes)   
bug16580 Firewall issue.jpg (106,837 bytes)   

peke

2020-05-08 19:25

developer   ~0057919

I think I found the reason. MM5 Installation didn't set firewall rules correctly and once I have added them manually MM5 started to be seen on SICINLAPTOP

Ludek

2020-05-10 18:01

developer   ~0057932

Could you please clarify how exactly MM5 Installation didn't set firewall rules correctly ?
MM5 is setting firewall rules upon install just for the default Windows firewall and just for MediaMonkey.exe and MediaMonkeyEngine.exe, but from the screenshot above it looks like you are using another firewall and the rules were somehow set automatically by Windows itself?

Note that those added by MM5 itself are named like "MediaMonkey auto-conf ..." : https://www.dropbox.com/s/21qz5xl7vgn6c6t/screenshot%202020-05-10%2020.00.06.png?dl=0

Ludek

2020-05-10 18:15

developer   ~0057933

Assigned back to me, seeing that the "MediaMonkey auto-conf ..." rules silently fails to add with this in the debug log:

[7264] MM5 [16060](R) Elevation moniker finished with result800401E4
[7264] MM5 [16060](R) The pszName parameter is not a properly formed display name.

peke

2020-05-10 21:05

developer   ~0057936

Last edited: 2020-05-10 21:07

View 2 revisions

For years now I am using Binisoft Windows Firewall Control https://binisoft.org/wfc (now malwarebytes and is free) that controls and setups Windows Firewall while reports connections like good old days ZoneAlarm Firewall and do not clutter anything or bottleneck system.

Re question: They were simply missing.

Ludek

2020-05-12 09:07

developer   ~0057963

Last edited: 2020-05-12 09:15

View 2 revisions

Fixed in 2248

i.e. fixed the silent failure of adding the "MediaMonkey auto-conf <number>" rules upon install.

peke

2020-05-15 02:14

developer   ~0058021

Verified 2248

They are now created on installation. Close after second confirmation.

Ludek

2020-05-20 12:00

developer   ~0058133

Last edited: 2020-05-22 11:09

View 4 revisions

Currently when user cancels the elevator then it is shown on next startup again.
This could be undesired on portable versions (when user does not have admin rights at all), details here: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=96595&p=468413#p468413

i.e. for portable version we should show the elevator just once (on the first run after install).
=> Fixed in 2251

peke

2020-05-22 18:32

developer   ~0058192

Verified 2251

Works, no annoying prompts on each start.

Test note: either cancel uac or create non admin Local user an dcancel the Admin login when asked.