View Issue Details

IDProjectCategoryView StatusLast Update
0016446MediaMonkey 5Main Panelpublic2021-10-11 10:45
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0 
Summary0016446: 'Pin it' is missing from grid item context menu
Description1) Go to Home screen
2) Right-click an artist there to pin it
=> 'Pin it' option is mising!!

The same goes for other items: album, genre, playlist, tracks etc.

The only way to pin it seems to use drag&drop to the Pinned node
Additional Informationhttps://www.mediamonkey.com/forum/viewtopic.php?f=30&t=96146
TagsNo tags attached.
Fixed in build2235

Relationships

related to 0014468 closedpetr Pinning improvements 
related to 0016967 closedLudek Can't remove Collections from Pinned items 
related to 0018404 closedpetr Pin It no longer available (regression 2507) 

Activities

Ludek

2020-03-23 12:27

developer   ~0057289

Last edited: 2020-03-23 13:07

View 6 revisions

1) Just realized that we moved the Pin/Unpin under the 'Send to' submenu.
i.e. right click > Send to > Pin it works.

I suppose that this was intentional?

While one can understand moving it under 'Send to' it makes harder to realize how to pin.
Maybe could be resolved by either:
a) renaming 'Send to' to 'Send to / pin'
b) adding 'Pin it' back just under 'Send to' item

I think that moving under 'Send to' is also problematic when the item is already pinned (as one would hardly expext the 'Unpin it' under 'Send to')
i.e. Send to > Unpit it

2) There is a bug, once user pins an item (via Send to > Pin it) then _all_ others items in 'Send to' menu shows 'Unpin to', even if the item is not pinned !!

3) Also, in Home view the drag&drop to the Pinned section (Pinned List element) does not work. Only drop to the 'Pinned' node works.

rusty

2020-03-24 02:38

administrator   ~0057308

1) Yes it was intentional (it was done as part of cleaning up the context menus because they were getting unwieldy). I think that the change might be confusing to a user who's pinned stuff from the main context menu in the past, but for new users, 'send to' is pretty logical. Note that part of the reason for keeping it buried a bit deeply is that this function isn't used often--it's primarily for setting up 'favorites'--a one-time operation.

I do agree, however, that 'Unpin' should be much more accessible--probably the first contextual item for any pinned item (we may also be able to eliminate some context menu entries from 'pinned' items).

2) I can't replicate, but I'm experiencing a possibly-related issue 0016448

Ludek

2020-03-24 16:53

developer   ~0057316

Last edited: 2020-03-24 20:21

View 3 revisions

1) OK, fixed in 2235
i.e. 'Pin it' remains under 'Send to' -- while 'Unpit it' is the very first item for items in the pinned list.

2) The bug seems to appear in the Home view only => fixed in 2235

3) Fixed in 2235

peke

2020-03-27 01:49

developer   ~0057372

Verified 2235

It works OK for me now.