View Issue Details

IDProjectCategoryView StatusLast Update
0016403MM5 Codec PackGeneralpublic2020-05-21 22:31
Reportermichal Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionduplicate 
Fixed in Version3.0 
Summary0016403: Some alac files trigger crash in f_aac_codec.dll
DescriptionIn AKM-695-96231 the user provided a file that triggers a crash in MM and his entire system. Michal has been able to replicate and found that it occurs with f_acc_codec.dll (not sure if it requires a codec pack update or not).

Note: the problem affects both MM4 and MM5.
Additional InformationPRT-164-78823
TagsNo tags attached.

Relationships

duplicate of 0016401 resolvedmichal AAC / Video codec plugin Some alac files trigger crash in f_aac_codec.dll 

Activities

michal

2020-02-26 09:04

developer   ~0056889

Last edited: 2020-02-26 09:04

View 2 revisions

Fixed in codec pack build 3.0.2 Problem was caused by mixed info in the file - it indicates sample size 24 bits in one place of the file's metadata header, but in the other place it shows 16 bits. The file is in fact 24 bits and such are not supported by this plugin (but can be played by f_alac_encdec).

peke

2020-05-10 23:08

developer   ~0057938

In remote session with user I have found one more file making the problems with MM5, It do not Crash MM5 but it makes MM5 just skips thru it.

Other players play it. File sent Offline.

michal

2020-05-12 07:23

developer   ~0057960

Fixed in build 3.0.3 of codec pack and build 2248 of MM5.

peke

2020-05-21 22:31

developer   ~0058175

Verified 2250

Tested and confirmed along MM4 1906