View Issue Details

IDProjectCategoryView StatusLast Update
0016401AAC / Video codec pluginCodecpublic2020-05-12 07:28
Reporterrusty 
PriorityurgentSeveritycrashReproducibilityalways
Status resolvedResolutionreopened 
Product Version 
Target VersionFixed in Version 
Summary0016401: Some alac files trigger crash in f_aac_codec.dll
DescriptionIn AKM-695-96231 the user provided a file that triggers a crash in MM and his entire system. Michal has been able to replicate and found that it occurs with f_acc_codec.dll (not sure if it requires a codec pack update or not).

Note: the problem affects both MM4 and MM5.
Additional InformationPRT-164-78823
TagsNo tags attached.
Fixed in build108

Relationships

has duplicate 0016403 closedmichal MM5 Codec Pack Some alac files trigger crash in f_aac_codec.dll 
related to 0016599 closedmichal MediaMonkey (current) Some ALAC files do not play. 

Activities

michal

2020-02-26 09:06

developer   ~0056890

Fixed in codec pack build 2.3.0.107. Problem was caused by mixed info in the file - it indicates sample size 24 bits in one place of the file's metadata header, but in the other place it shows 16 bits. The file is in fact 24 bits and such are not supported by this plugin (but can be played by f_alac_encdec).

peke

2020-02-28 01:31

developer   ~0056933

Verified 1897/107

Files play OK.

peke

2020-05-10 23:10

developer   ~0057939

In remote session with user I have found one more file Crash MM4. Reopened 0016403 for fix in MM5

Other players play it. File sent Offline.

michal

2020-05-12 07:17

developer   ~0057959

Fixed in build 108.