View Issue Details

IDProjectCategoryView StatusLast Update
0016293MediaMonkey for AndroidPlaylistspublic2020-08-16 23:54
Reportermartin Assigned To 
PriorityurgentSeveritymajorReproducibilityhave not tried
Status resolvedResolutionreopened 
PlatformAndroidOS-OS Version9
Product Version1.3.7 
Target Version1.4.0Fixed in Version1.4.0 
Summary0016293: MMA loses playlist after sync (Android 10)
Descriptionhttp://www.mediamonkey.com/forum/viewtopic.php?f=21&t=95725&sid=d421a7edf270e7e6e09a037aa539cb41
https://appcenter.ms/users/rs-y9ha/apps/MediaMonkey/crashes/errors/2377878425/reports
https://appcenter.ms/users/rs-y9ha/apps/MediaMonkey/crashes/errors/3854342334/reports
https://appcenter.ms/users/rs-y9ha/apps/MediaMonkey/crashes/errors/40175508/reports
TagsNo tags attached.
Fixed in build934

Activities

peke

2020-02-01 03:11

developer   ~0056474

Log posted: F7QSJJZ39Q

https://www.mediamonkey.com/forum/viewtopic.php?p=464855#p464855

martin

2020-02-18 00:28

developer   ~0056702

Fixed in build 1.3.7.904

peke

2020-03-04 00:56

developer   ~0057033

Verified 905

Unable to reproduce.

rusty

2020-03-20 02:31

administrator   ~0057240

Verified 905 on an S10 running Android 10.

peke

2020-06-17 11:34

developer   ~0058577

Reopen based on User post https://www.mediamonkey.com/forum/viewtopic.php?p=469342#p469342

rusty

2020-08-05 18:51

administrator   ~0059245

I'd suggest the following (note: there are minor string changes to the other related items for consistency):

Choose library folders
Choose and grant access to folders to include / refresh in the library.

Update playlists from other apps
Playlist changes made by other apps will appear in the library when it's refreshed. Disable if other apps corrupt ?synced? playlists.

Check for new/changed media
Manually refresh the library to show new/modified content.

martin

2020-08-06 08:38

developer   ~0059250

Fixed in build 1.4.0.0932

rusty

2020-08-07 13:21

administrator   ~0059258

I haven't tested the functionality, but the location of the new entry seems to be in a confusing location. i.e. the setting to 'Update playlists from other apps' would seem to apply to any playlist--not just synced playlists (e.g. if the user create a playlist in MM, and the playlist is then corrupted by other apps). If that's the case, then it belongs with the other content scanning settings. If it isn't the case, then the wording should be adjusted slightly.

martin

2020-08-12 11:11

developer   ~0059347

Currently, it's related to synced playlists only, what about:
"Update synced playlists from other apps"

rusty

2020-08-12 20:56

administrator   ~0059353

As discussed offline, although the problem occurs most often with synced playlists, it's generic to any playlists created in MMA. Since the problem is general (i.e. not only with synced playlists), then it would make sense for the fix to be general.

In that case, we can tweak the wording to the following and move it out of the sync section:
Update playlists from other apps
Playlist changes made by other apps will appear in the library when it's refreshed. Disable if other apps corrupt playlists.

martin

2020-08-13 10:25

developer   ~0059380

Fixed in build 1.4.0.933

rusty

2020-08-14 03:14

administrator   ~0059401

I'm unable to test the fix since I can't replicate the problem. However, the setting should appear in the General section along with the other 'scanning' settings. e.g.

1) Choose library folders
2) Update playlists from other apps
3) Check for new/changed media

martin

2020-08-15 22:00

developer   ~0059420

Fixed in build 1.4.0.934

rusty

2020-08-16 03:33

administrator   ~0059422

Verified UI in 934. Leaving as 'fixed' for functional verification.

peke

2020-08-16 23:54

developer   ~0059426

Verified 934/935

Unable to reproduce on Android 9 and 8