View Issue Details

IDProjectCategoryView StatusLast Update
0016099MediaMonkey 5Track Browserpublic2019-11-29 07:27
Reporterrusty 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0016099: Editing Artist metadata fails in some cases
DescriptionIn some cases, editing the Artist label (the label below the Artist image in Search|Artists) or the Artist metadata that appears at the top of the Artist screen doesn't work:

1 Search for 'tragically hip'
2 Attempt to rename Artist by right-clicking on the Artist:Tragically HipiTunes and changing to The Tragically Hip
3 Click Artist:The Tragically Hip1. In the Artist view, click the Artist name and change it to The Tragically Hip
4 Go back to the Search --> the Artists aren't renamed for both cases 1 & 2!
5 Initiate search for 'Tragically hip' (to confirm that it's not a refresh issue) --> the resulting Artists aren't renamed
6 Hover over Artist 'The Tragically Hip...' in order to see the full artist name
-->Crashlog A04C2EEF!

See: https://www.screencast.com/t/ysP3vY15
Debug logs posted to ftp

Further investigation shows that there's a disconnect between the label that appears below each artist image and the looked up Artist Name / Artist/Album Artist metadata (in addition to the known distinction between the looked up Artist Name and the Album/Album Artist metadata).

Test Note: I would expect that if the user changes the Artist Name either by modifying the label below the image OR by modifying the looked up metadata, that all tracks containing the original text in the Looked up metadata/Artist/Album Artist would be updated with the revised text (the implication being that Looked up Artist/Artist/Album Artist metadata that was different to begin with--either because it was different or because it was a multiple attribute--is left alone).
TagsNo tags attached.
Fixed in build2217

Activities

Ludek

2019-11-08 11:24

developer   ~0055269

Last edited: 2019-11-08 12:37

View 8 revisions

The crash A04C2EEF is fixed in 2212

Could you please upload your current database?

I used the database uploaded re the issue 0016086, but it is old database (from August) that actually includes four variants of The Tragically Hip, see:
https://www.dropbox.com/s/t1x1x2s1rdvqhmx/Screenshot%202019-11-08%2012.49.27.png?dl=0

but each one correctly jumps to corresponding artist including the one track with the corresponding variant of the artist:
https://www.dropbox.com/s/eqj7eyrclo4n83c/Screenshot%202019-11-08%2012.46.01.png?dl=0

EDIT: Testing this more it seems that the issue appears when also the Composer tag is "The Tragically Hip1". Once the composer is also renamed then the artist disappears from the search results.
So it is rather presentation issue in the search results (showing Composers mixed with artists!)

Assigned back to me to look into it.

Ludek

2019-11-08 16:15

developer   ~0055276

Last edited: 2019-11-08 16:17

View 3 revisions

This is really long-standing issue (appears also in MM4), but is hard to notice since it appears only for tracks where Artist has the same value as Composer and only when the Artist is renamed (Composer left unchanged), then the dummy Artist-Song link remains (ArtistsSongs entry) although it should be deleted.
Workaround is to rename also the Composer.

Ludek

2019-11-08 17:44

developer   ~0055280

Last edited: 2019-11-08 17:45

View 2 revisions

Fixed in 2212.

Test note: Tested on the original Rusty's database from 0016086 (FTP/MM5/bugs/bug16086/)

rusty

2019-11-15 15:08

administrator   ~0055361

Verified 2212.

Ludek

2019-11-28 19:35

developer   ~0055538

Last edited: 2019-11-28 20:24

View 11 revisions

Re-opened: During fixing this issue a regression was introduced (found by unit tests) that is worse than the original issue.

Editing any property of a track destroys the track links to Composer/Lyricists/Conductor...
i.e. after the edit the track disappears from Music > Composers > [Composer 1] view!! Even if it should still be there -- as the "Composer 1" is still assigned to the track (as can be seen in Properties)
Raising to immediate as it corrupts the database (ArtistsSongs table data). In addition such a composers are no longer visible/listed over DLNA then + probably further (hard to predict) issues.

=> Fixed in 2217

Test note: To replicate the issue the track needs to have different (and non-empty) artist and composer values.
Remedy of this issue is mass edit of the affected tracks in build 2217+

peke

2019-11-29 02:27

developer   ~0055540

Verified 2217

I can confirm corruption of Classical tracks in 2215 and that it fixes issues in 2217

Test Note: Rebuild of Library is needed in 2217 to recreate track links to Composer/Lyricists/Conductor...