View Issue Details

IDProjectCategoryView StatusLast Update
0014645MediaMonkey 5DLNA/UPnPpublic2018-05-29 16:32
ReporterLudek 
PriorityurgentSeverityminorReproducibilityhave not tried
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0014645: Chromecast audio not as streaming option
DescriptionUser is saying that "Chromecast audio" doesn't appear as a streaming option.
Reported as http://forum.mediamonkey.com/viewtopic.php?f=30&t=89308&p=442941#p442933
Additional InformationWe will probably need to switch the discovery protocol from DIAL over SSDP to mDNS. Details at:
https://www.cisco.com/c/en/us/support/docs/wireless-mobility/wireless-mobility/119017-config-chromecast-mdns-wlc-00.html
https://github.com/jloutsenhizer/CR-Cast/wiki/Chromecast-Implementation-Documentation-WIP
http://elatov.github.io/2017/01/media-casting-and-streaming-options/
TagsNo tags attached.
Fixed in build2108

Relationships

related to 0014587 resolvedLudek Chromecast fails to announce sometimes (housekeeping of old entries needed) 

Activities

Ludek

2018-02-12 22:49

developer   ~0049622

Could be related to https://github.com/masmu/pulseaudio-dlna/issues/107

Ludek

2018-02-15 10:49

developer   ~0049629

Last edited: 2018-02-15 10:50

View 3 revisions

By the info provided by user (at http://forum.mediamonkey.com/viewtopic.php?f=30&t=89308&p=442941#p442977 ) it seems that SSDP discovery really isn't working for Chromecast audio anymore (with 1.28.x release). We will need to switch the discovery method to mDNS, also for the manual addition the link http://192.168.1.100:8008/ssdp/device-desc.xml returns 404, we will need to use http://192.168.1.100:8008/setup/eureka_info?options=detail JSON instead

Ludek

2018-02-16 16:03

developer   ~0049632

Last edited: 2018-02-16 16:06

View 3 revisions

mDNS discovery implemented in 2090 (currently we use both methods - SSDP and mDNS for discovering Google cast devices)

Ludek

2018-02-16 16:20

developer   ~0049633

Re-opened, because I've just found that my solution works only when Apple's Bonjour is installed.

Ludek

2018-02-19 19:24

developer   ~0049638

Implemented mDNS discovery using Indy in 2090

peke

2018-03-06 23:00

developer   ~0049677

Verified 2090 No regressions on Nexus Player

Ludek

2018-05-28 22:34

developer   ~0050405

Re-opened:
1) A user still indicate that it isn't working for him:
https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=89308&e=1&view=unread#p445498

2) The new mDNS discovery method can cause crash for some users (even without Chromecast on network):
#IAN-428-42013 and http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=89817&start=15

Ludek

2018-05-28 22:37

developer   ~0050406

2) Is fixed in 2108

Ludek

2018-05-29 09:01

developer   ~0050410

1) User Davo confirmed that he can see and stream to "Chromecast Audio" now: https://www.mediamonkey.com/forum/viewtopic.php?f=30&t=89308&e=1&view=unread#p445560

rusty

2018-05-29 16:32

administrator   ~0050417

Works for me in 2108.