View Issue Details

IDProjectCategoryView StatusLast Update
0014587MediaMonkey 5Playbackpublic2020-10-11 20:29
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityunable to reproduce
Status closedResolutionreopened 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0014587: Chromecast fails to announce sometimes (housekeeping of old entries needed)
DescriptionJiri is experiencing issue that his Chromecast is not announcing and MM5 often doesn't see it after restart.

We could implement a workaround, MM5 could just remember the Chromecast IP/MAC/Port from the last start and try to ping it on the next MM5 start.
TagsNo tags attached.
Fixed in build2135

Relationships

related to 0014645 closedLudek Chromecast audio not as streaming option 

Activities

Ludek

2017-12-15 11:59

developer   ~0049419

Last edited: 2017-12-15 17:38

View 3 revisions

Fixed in 2083. Chromecast devices are remembered (persistent) after MM restart now.

Ludek

2018-08-21 12:02

developer   ~0050949

Last edited: 2018-08-21 12:04

View 2 revisions

Re-opened:
We will need to add some kind of housekeeping, the old Chromecasts seem to remain as ghosts: http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=89308&p=448595#p448517

We should also review whether the caching is still needed as we added mDNS discovery in the course of 0014645

Ludek

2018-08-22 10:19

developer   ~0050958

Fixed in 2121

peke

2018-09-14 02:46

developer   ~0051104

Verified 2121

Ludek

2018-11-20 17:33

developer   ~0051580

Re-opened due to housekeeping issues, they are still valid

Ludek

2018-11-21 15:56

developer   ~0051604

Last edited: 2018-11-21 17:19

View 3 revisions

Fixed in 2135

Detected remote players are still stored in persistent.json, but with 'last_seen' timestamp, if 'last_seen' is older than one week then they are not added.

peke

2020-10-11 20:29

developer   ~0059813

Verified 2269

Suddenly my Nexus player was missing in tests and as it changed WiFi networl it was not in LAN along with MM5 anymore for more than a week it was not shown. Closing works as designed.