View Issue Details

IDProjectCategoryView StatusLast Update
0011381MediaMonkey for AndroidUPnP / Castingpublic2014-09-29 07:24
Reporterrusty 
PriorityimmediateSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version1.0.4 
Target Version1.0.4Fixed in Version1.0.7 
Summary0011381: Documentation: Some users can't see MMW UPnP server
DescriptionThere are several reports from users who can't see the MMW server using MMA, at least one of them being able to see it using Bubble UPnP.

I have seen this on occasion as well, but for some users it appears to be a consistent issue.

Any ideas? I was wondering if it would make sense to add a 'Refresh' button to the UPnP servers and Select Sync Servers screens.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=21&t=74141
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=73994
RNE-909428
Tagsdoc_faq
Fixed in build305

Relationships

related to 0011123 closedLudek MediaMonkey (current) UPnP connection issues 
related to 0011774 closedLudek MediaMonkey (current) Intermittent failure to find MMW Server 
related to 0011374 closedmarek MediaMonkey for Android 'Waiting for the remote server...' on screen timeout 
related to 0011138 closedmartin MediaMonkey for Android UPnP discovering is sometimes too slow, manual option is needed 
related to 0011775 closedmarek MediaMonkey for Android [Troubleshooting] button does nothing 

Activities

Ludek

2013-10-17 20:26

developer   ~0037933

Last edited: 2013-10-17 20:31

View 3 revisions

If Bubble UPnP see the server then it needs to be a problem in MMA or Cling lib.

I don't think it is an issue with Access Control (based on MAC address) because both Bubble UPnP and MMA resides on the same device thus should have the same MAC address.
And in addition even if the client would be set to ignore the MAC, the server would be still visible, just would show "Access Denied" on attempt to browse it.

marek

2013-10-18 08:27

developer   ~0037937

Last edited: 2013-10-18 08:39

View 3 revisions

I also observe these issues sometimes. But it isn't on MMA side. The reason why somebody see it in Bubble UPnP is timing. Sometimes when I retry it in MMA, MMW appears. But its refresh time is much longer than refresh time of other servers. I think that it related to Windows sleep or hibernation mode. Because it usually appears after that. When I restart MMW, the issue immediately disappears.

MMA doesn't filter it in any way. So when users see other UPnP servers (Twonky), it is certainly this kind of issue - server is not responding.

Btw. I also tried Bubble Upnp once in this situation and didn't see MMW. But when you wait 1-2 minutes, it appears...in MMA as well.

But there might be probably other issues, because it looks like user's issues are permanent.

Ludek

2013-10-18 11:54

developer   ~0037942

Last edited: 2013-10-18 16:28

View 5 revisions

Waiting what users will reply, we can debug then futher (I will prepare UPnP.dll with more debug messages to see which requests/responses failed)

I added two new debug messages to build 1666:
Received M-SEARCH for ssdp:all from 192.168.0.100:52308
Ignoring M-SEARCH from 192.168.0.100:388 (invalid source port)

The second happens when port is < 1024 or is 1900. The port is the only difference between BubbleUPnP and MMA that I see ATM.
It seems that BubbleUPnP uses port from dynamic port range area for TCP/UDP (49152–65535), but MMA has the random port number lower (38388 in my case).

peke

2013-10-21 17:51

developer   ~0037971

Last edited: 2013-10-21 18:15

View 3 revisions

Test: I confirmed with few users that changing port to 5000 (UPnP) also fixes MMW server showing in MMA.

Further analyze showed that even router firewall locks ports. Multicast packets to port 5000 passes. Problem arise when WMP or other Media Server occupy port 5000 which Ludek fixed in earlier builds regarding bug 0011123.

Ludek

2013-11-27 12:55

developer   ~0038396

Peke, you probably mean http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=73994#p376317 ?

It is strange that changing port to 5000 helped, I don't see a real reason, but from what the user wrote: " MMA now sees the MM Server in UPnP which is a breakthrough. However, it still does not find the server under -> Options -> Select Sync Server (...<searching>)." it looks that the problam is in MMA or rather the problem has a random nature?

jiri

2013-11-27 15:30

administrator   ~0038400

Assigning to Peke to try to find out more and to get a MMW log from them.

Ludek

2013-11-28 10:45

developer   ~0038407

Last edited: 2013-11-28 12:40

View 3 revisions

Port 5000 is commonly used by other apps/servers so we should rather avoid using this port to prevent conflict (Port TCP 5000 is also used by Apple AirPlay when mirroring the iPad)

Note that MMW doesn't use 4000 by default, 4000 is just a hack if you want MMW to see its own server which can be used for testing purposes.

MMW uses (by default) random port from dynamic port range area (from 49152 to 65535)

Looking what ports are used by the others servers:
- WMP always uses 2869 (so we cannot use this port)
- Asset UPnP uses a random port, 26125 in my case
- serviio uses 8895
- foobar, random port from dynamic range area (56923 in my case)

So we might lower the default port, but I guess that it won't help much, because if firewall is open only for well known ports then user will always need to open the MMW's server port.

So my guess is that we should just add KB article about this.
It seems that all servers solves this issue via FAQ, e.g. http://serviio.org/component/content/article?id=21#q1

So the KB article should contain both methods of solving:
1) How to change MM server port in MM interface
2) How to find default MM server port in order to allow this port in client firewall

rusty

2014-01-27 14:11

administrator   ~0039379

Resolved via kb article at: http://www.mediamonkey.com/support/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=163&nav=0,13

marek

2014-09-29 07:24

developer   ~0040635

I am now on very bad wifi and I have maybe fixed some issues with UPnP servers discovery. Sometimes the search message is lost and only some servers respond. So now, each 3 seconds is search message resend. If nothing new is found after 5 seconds, the discovery process is ended.

Fixed in build 305