View Issue Details

IDProjectCategoryView StatusLast Update
0006492MediaMonkey (current)Skinspublic2011-01-12 23:59
Reporterrusty 
PriorityimmediateSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006492: Large icons for common devices
DescriptionMM should include at least several icons for several common devices as described in 0006490.

Required icon sizes are:
Small icon (for tree): 16x16
Large icon (for device panel): between 64x64 and 128x128

1) Generic device (to go with the generic 16x16 icon)
2) iPod
3) iPad
4) iPhone
5) iPod Shuffle
6) iPod Touch
TagsNo tags attached.
Fixed in build1335

Relationships

related to 0006640 closedLudek Save / Load Device Profiles 
related to 0007001 closedLudek Device icon isn't shown on skinless version 
child of 0006490 closedLudek New Sync UI 

Activities

stephen_platt

2010-09-21 02:40

developer   ~0020557

I have several free images that could be useful for this.

rusty

2010-09-21 17:07

administrator   ~0020559

Stephen, if you have any such icons, please post them (or links to them), indicating the source/license. Thanks.

stephen_platt

2010-09-21 17:21

developer   ~0020560

http://pierocksmysocks.deviantart.com/art/Mobile-Device-Icons-66358891
http://www.vecteezy.com/Technology/10121-Vector-iPad
http://www.vecteezy.com/Technology/5681-iPhone-HD-iOS4
http://www.vecteezy.com/Technology/10014-Android-OS-Phone-Vector
http://www.freeiconsweb.com/iPod_Icons_Pack.htm
http://p.yusukekamiyamane.com/

These are all the sources for the images I have. Not sure about the licensing on them other than the last link (fugue icons by pinvoke which we already credited). I have the images compiled together at:
https://sites.google.com/site/mediamonkeyfansite/file-cabinet/Deviceicons.7z?attredirects=0&d=1

Ludek

2010-10-11 23:05

developer   ~0020728

Moved from 0006490:

b) Show larger icon (should be included with the device plug-ins). Note that currently, the device plug-in can return a path to icon file in case it's a known device - which is the case of iPods (only two icons for all of them) and about 4 specific WMDM devices (mostly for OEMs). These icons are supposed to be 16x16, so there's nothing nice for the Summary page. What could be improved:
 - i. Some devices return their icon over WMDM interface (even large one), it could be used.
 - ii. We could make a collection of few most common icons and device plug-ins would provide them to the main application (iPods, etc.). Note that we should make sure that we aren't used any copyrighted work!
 - iii. We should have one large generic icon, to be used when neither a nor b applies. This seems to be the number 1 priority for now.
c) We could let user to edit the icon (by double clicking it, or right-click menu?). This edited icon could be sent to us as a part of device profile when user does so.

Ludek

2010-10-11 23:07

developer   ~0020729

I think that at least 100x200 icons would be nice (like in iTunes), see my sample icon in build 1315.

Ludek

2010-11-15 12:35

developer   ~0021354

Last edited: 2010-11-15 15:09

View 2 revisions

In the build 1326 is implemented the ability to change the image and added some default images.

You can change the image via Device Configuration -> Options -> Device Profile
and there you can select a non-default custom image, image is auto-resized to 150x200 and the original ratio is kept.

I added only iPod, iPhone, BlackBerry default images so far (stored in MediaMonkey/Plugins/DeviceImages/)

So review this in the build 1326 and assign to me once you get the default images.

Ludek

2010-11-29 13:45

developer   ~0021512

Last edited: 2010-11-29 13:46

View 2 revisions

In build 1329 I added some others icons from the Stephan's package (for iPod Shuffle, iPod Nano, iPhone4, iPad), so review whether the copyright is all right or get some others icons.

Ludek

2010-12-10 13:20

developer   ~0021717

Last edited: 2010-12-10 13:21

View 2 revisions

Added new Android, Nokia icons in build 1334
+ fixed the old icons
+ added the icon for unknown device (same as Android so far)

Ludek

2010-12-16 14:17

developer   ~0021864

Changed icon format to 256x256 in order to be compatible with 0006979

Current resize algorithm:
- if width or height is large than 256 then it is auto-resized to 256, but the original ratio is kept
- if width and height is smaller then 128 then it is auto-resized to 128, but the original ratio is kept, Mitchel's filter is used so it looks fine even for very small (16x16) icons

peke

2011-01-12 23:59

developer   ~0022335

verified 1343