View Issue Details

IDProjectCategoryView StatusLast Update
0006640MediaMonkey (current)Synchronizationpublic2011-06-15 19:53
Reporterrusty 
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006640: Save / Load Device Profiles
DescriptionThe goal of this feature is that ALL devices should be as plug and play as possible--the user's focus should be on configuring whatever files they wish to sync.

Device profiles should consist of:

Device Identification:
- Device image
- Device Name
- Device Firmware version

Device configuration settings:

Here's how this would generally work. User plugin in the device and:

1) MM recognizes the device ID and configures sync settings appropriately, along with the device name and image.

2) MM doesn't recognize the device ID and
a) recognizes that the device is an Android device, and configures the settings according to a generic Android profile, and loads a generic device image.

b) recognizes that the device is a Blackberry device, and proceeds as with 2a)

c) recognizes that the device is an MTP device, and proceeds as with 2a) (except that settings and images are based on whatever MTP tell MediaMonkey).

3) MM doesn't recognise the device ID and doesn't recognise the device type (e.g. if it's a Palm device that doesn't masquerade as an iPhone). In this case, the message would be:
"MediaMonkey does not recognize this device. You can configure synchronization settings manually, or visit the MediaMonkey device database to get device-specific information." (links to devices.mediamonkey.com)

4) In cases where the user wishes to load a profile to replace the default settings, it would be ideal if the 'Profiles' were packaged as addons so that the user can just double click them. Otherwise, users will have to download profiles to a directory, and then manually load them. This could be achieve via a new home panel in the 'Options' tab. It would contain:
Device image (same as in the summary screen) with [Change image...]

Device settings for various devices can be imported from the MediaMonkey <Device Database>:
[Import device options...]
[Export device options...]
[Reset device options...]


5) In cases where an advanced user configures a profile on their own, they can save the profile and share it with other users via the Wiki's device database.
Additional InformationSee UI proposal at:
http://www.jirihajek.net/MMwiki/index.php/MM_4.0_UI#Device_Sync
Tagstodoc
Fixed in build1351

Relationships

related to 0006492 closedLudek Large icons for common devices 
related to 0007522 feedbackjiri Sync Path Is Ignored by wmdm plugin 

Activities

jiri

2010-11-11 02:47

administrator   ~0021308

Ludek, please implement 4), technical details follow:

a. Changed device image should be stored in user's folder and it's filename stored in DB - so that it's properly used.
We could also add the same configuration for device icon (shown in tree as a part of the device node).

b. <Device Database> should point to http://www.mediamonkey.com/deviceprofiles that will redirect to the proper place (probably a forum for sharing device profiles).

c. Import and Export buttons should read/write a simple XML stored in a ZIP file with MMDC extension containing:
 - Device ID - needs to be discussed to be retrieved from misc devices/plug-ins
 - Device Options (playlists, etc.)
 - Supported formats (!) - the most important part
 - Auto-conversion rules
 - Device Image (if non-default is assigned) also ZIPped

[Reset Options] should restore to defaults as retrieved from the device plug-in, particularly re. Supported formats.

jiri

2010-12-10 10:29

administrator   ~0021714

As discussed over IM, the only remaining is to added Device ID to the XML. Then also a generic image should be automatically assigned to an unknown device (currently it's Blackberry image).

There isn't much more that could be done atm, feel free to resolve then.

Ludek

2010-12-10 13:22

developer   ~0021718

Fixed in 1334

peke

2010-12-14 12:08

developer   ~0021810

I agree on 2. That it seams to be fine.

rusty

2011-02-23 22:21

administrator   ~0023360

I don't think that either of the holes are that critical.
1. the profiles will often include items that aren't optimized for the user. Moreover, users will likely want to upgrade to Gold in order to be able to auto-convert to the formats that aren't supported in MM Gold.

2. This is the same as in the past--basic auto-conversion profiles are included even for non-gold users.

3. Another point that 1) raises is what happens when the Device Profile has auto-conversion rules that aren't supported by the version of MediaMonkey that's installed? Perhaps such rules should be greyed out, and if the user double-clicks them, a dialog should appear indicating:
'This conversion rule requires [MediaMonkey Gold | MediaMonkey encoder pack]. For more information, click here.'

jiri

2011-02-24 08:33

administrator   ~0023365

3. Since it can't be easily decided which rule really does require the codec pack (depends on what's already installed and on particular videos to be synced), I think that it's enough to have the current 'Gold-only' warning there.

rusty

2011-02-24 15:50

administrator   ~0023380

OK, so no changes required. Reverting back to 'fixed'.

jiri

2011-02-25 21:09

administrator   ~0023417

There's a problem with
SuppVFrms=...
item written to the file - it's just Base64 encoded string. It should be split to individual values in order to be readable and also in order to be ready for future modifications of the structure.

Ludek

2011-02-28 12:02

developer   ~0023448

Fixed in build 1351.

peke

2011-05-02 23:17

developer   ~0024747

Verified 1368