View Issue Details

IDProjectCategoryView StatusLast Update
0006490MediaMonkey (current)Synchronizationpublic2011-02-07 20:42
Reporterrusty 
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006490: New Sync UI
DescriptionThe spec for the new Synch UI is at:
http://www.jirihajek.net/MMwiki/index.php/MM_4.0_UI#Device_Sync
Additional InformationDocumentation notes:
The sync rules that appear below a collection appear based on the 'Type' of tracks contained within a collection.

e.g. if a collection is defined as Type=[Video, Music], then the rules below the sync list (e.g. Sync [10 most recent] unplayed videos) will consider the 'Type' to be:

if the collection has Type=Video then collection is classified as Video collection
else
if Type=TV then collection is classified as TVcollection
else
if Type=Podcast or Type=Video Podcast then collection is classified as Podcast collection
else
collection is classified as Music collection

For example if a Collection is defined as Type=[Video, Music], then the rules displayed below the auto-sync list would be for Type=Video.
TagsNo tags attached.
Fixed in build1324

Relationships

parent of 0006492 closedLudek Large icons for common devices 
related to 0006491 closedLudek MTP Devices should use root folder for in-place configuration 
related to 0006622 closedLudek Synchronization configuration improvements 
related to 0007597 resolvedLudek Selection issues in the device config dialog 

Activities

rusty

2010-09-20 22:07

administrator   ~0020555

In general, the UI is great. What follows are some of the inconsistencies noted vs. the implementation in build 1312.


1. Window management issues:
a) Remove Cancel button - user can cancel by navigating away.
b) When navigating away and something has been changed, give user a chance to save it (by showing a confirmation).
How about "You have changed the settings for "xxxxxxxxx". Would you like to apply these changes?
[Apply] [Cancel]"
c) Clicking a 'new tab' triggers a duplicate instance of the config dialog. What should happen is that adding a new tab is supposed to add the 'home' tab rather than a copy of the existing tab.
d) Similarly, users can navigate to their device when another tab is already open with an instance. I think that the solution might be that when the user clicks another tab, the tab closes (after giving the warning described in 1b) above).
e) Currently when the dialog is shown in the main window and user clicks Configure device, the dialog is shown in its own window and it disappears from the main window. It doesn't look good, we should change it.
Jiri indicated: I'm not sure about the best solution, maybe to simply show a second copy of the dialog? Disabling it completely would cause that it wouldn't also be accessible for devices that aren't connected to PC.
I would suggest that this should be handled in the same manner as 1d) i.e. the user should be given the warning from 1b) prior to the original dialog closing.

2) Misc. UI Issues (when device is selected):
a) Toolbar commands aren't contextually relevant (they should be e.g. Auto-sync, Eject, Rebuild DB, Play Now, Play Next, Play Last, Edit)
b) If the MM window is changed from maximized --> intermediate size window --> sync config options window doesn't resize correctly (it narrows the playlist window to almost nothing)
c) 'Music' and 'Audiobook' icons should probably be consistent by default across the Libary and Device icons, if possible.
d) The standalone version of the dialog shows strange artifacts near Tabs.

2. Capacity graphical indicator:
a) By clicking it, it could change between Bytes, Time and Count. E.g. 'Capacity: 5 GB, Audio: 1 GB, ...', changes to 'Capacity: 5 GB, Audio: 1,4 hours...' and then to 'Capacity: 5 GB, Audio: 231 tracks' (in contrast to the original spec in the wiki).
b) In a future build we can draw it ourselves (don't use the standard Progress component) and use different colors for each type of content.
c) The indicator should show 'Capacity', and 'To Sync', to the left and right of the capacity indicator rather than within it
d) For 'Used' space it should display as 'Used: xx (audio: yy, video: zz, Other: aa)' on the left margin of the indicator
e) For 'Free' space it should display 'Free: aa' on the right margin of the indicator
Note: intent here is to visually differentiate content on the device from Capacity and Amount to sync.

3. Summary page: Somehow better use the space it provides. Some suggestions:
a) Instead of Device details: start with device name it a large font (name should be editable on this page if the underlying framework allows the device name to be edited), like: 'Jiri's iPhone'.
b) Show larger icon (should be included with the device plug-ins). Note that currently, the device plug-in can return a path to icon file in case it's a known device - which is the case of iPods (only two icons for all of them) and about 4 specific WMDM devices (mostly for OEMs). These icons are supposed to be 16x16, so there's nothing nice for the Summary page. What could be improved:
 - i. Some devices return their icon over WMDM interface (even large one), it could be used.
 - ii. We could make a collection of few most common icons and device plug-ins would provide them to the main application (iPods, etc.). Note that we should make sure that we aren't used any copyrighted work!
 - iii. We should have one large generic icon, to be used when neither a nor b applies. This seems to be the number 1 priority for now.
c) We could let user to edit the icon (by double clicking it, or right-click menu?). This edited icon could be sent to us as a part of device profile when user does so.
d) The option unmount the device as soon as auto-sync is complete is currently missing. It can be added to the Summary page.

4) Autosync tab:
a) Artist&Album Artist should be displayed in the same manner as in the source Collection (i.e. currently it's always Artist&Album Artist, but if the source collection displays Artist, Album Artist, and Artist&Album Artist, then all three should be displayed.
b) 'Sync random subset of selected Music and Playlists up to device capacity' should be changed to 'Sync random subset of selected files up to device capacity' (playlists should be excluded from the logic, and 'files' should be used instead of 'Music' because it includes Music Videos--I believe they are because the option isn't present on the playlists dialog).
c) The user should be able to use different 'random subset' settings for different collections. When that happens, the ratio should probably be based on the relatives sizes of the selections (by time?). e.g. Collection A: 60 hours are selected and the option is enabled. Collection B: 40 hours are selected and the option is disabled. Collection c: 20 hours selected and the option is enabled.
---> All 40 hours of collection B should sync, and of the remaining 30 hours of space on the device, collection A should take up 66% by time, and collection c: 33%
d) Filling the checkbox for a Collection e.g. 'Podcasts' doesn't cause the associated tree to appear. It should, so that the user sees the effect of selecting the node in question, and so that the user can configure the associated options.
To replicate: click with the cursor on 'Music' but don't click the 'Music' checkbox. --> settings for music appear on the screen. Then click the checkbox for Podcasts (without clicking the Podcast text) ---> The music tree / settings are still displayed!!
e) Selecting a top-level Music, Classical Music, or Music Video node causes the 'Sync random subset...' options to be greyed out. They shouldn't be greyed out, because the user should be able to configure a random subset of the collection to sync if there's insufficient space.
f) Selecting the top-level Podcast node causes the podcast options (Sync: _all, 1 most recent, etc._ , _episodes of selected Podcasts, unplayed episodes....) to be disabled (even though they're not greyed out). They shouldn't be disabled--the user should still be able to set the podcast options to be applied to the full set of selected podcasts.
g) Selecting any second-level 'root' node has no effect. (e.g. selecting Artist&Album Artist has no effect). We could either:
 - i) display such nodes without a checkbox
 - ii) disabled the top-level checkboxes
 - iii) indicate selection status by showing e.g. +Genre (20 items selected)
h) Selecting a top-level video node (containing video nodes on the network) causes MM to start 'calculating...' the size of the selection, and there's no way for the user to switch to another node when this is happening!! A log of this issue was provided via e-mail, and it appears related to the fact that MM tries to unlock all the video files on the network and the operation freezes and MM crashes (why would it have to unlock every file? Aren't file sizes stored during the scanning process?).

10) iPhone:
a) Only attributes are Artist, Album, Genre: can't it also show classical music 'Composer' attribute that is stored to the iPhone?
b) The 'Destination' configuration is irrelevant so it should be hidden (or greyed out)

Ludek

2010-10-11 23:00

developer   ~0020727

1. Window management issues:
a) Fixed
b) Fixed
c) Not sure what the 'home' tab should be, but I resolved it this way:
There is no duplicate instance, but if an instance is already opened then the opened instance is used, thus it is actually the same one and any change there is changed also on the another tab.
This fixes also d).
e) Fixed: removed 'Configure device' from the context menu and if user accesses the same device from the 'Options->Portable Devices' then the warning is used (as suggested). For devices that aren't connected to PC there is always only one dialog shown (from the Options->Portable Devices), so there isn't a problem.


2) Misc. UI Issues (when device is selected):
a) Fixed
b) Fixed
c) Fixed
d) Fixed

2. Capacity graphical indicator:
a) Fixed
b) Fixed
c) Fixed
d) Fixed by introducing the new "iTunes like" graphical indicator.
e) Fixed

3. Summary page: Somehow better use the space it provides. Some suggestions:
a) Fixed
b) Introduced one sample icon, the rest will be fixed as 0006492 as I am waiting for the icons.
c) Moved to 0006492
d) The option "unmount the device as soon as auto-sync is complete" is not missing, it is only hidden for devices that doesn't support it (like iPhone), I made it as disabled in such a case, but Jiri wanted me to hide it completely (if it is not supported).

4) Autosync tab:
a) Fixed
b) Fixed
c) Fixed
d) Fixed
e) Fixed
f) Fixed
g) Fixed by using solution ii) disabled the top-level checkboxes
h) Fixed

10) iPhone:
a) Will be fixed similarly as 0006491
b) Fixed (aslo 'Playlists' is hidden for devices that doesn't support M3U playlists or M3U playlists configuration)

rusty

2010-10-14 21:54

administrator   ~0020774

Tested 1316. Looks really good--almost done. Here are the remaining items I see:

1 c) What I meant is that when a new tab is clicked, MM should open the 'Home page' tab, meaning the web page that appears when MM is first installed. Don't bother fixing--it's tracked at 0005925 (item 5)

2 UI Issues:
a) When the device is selected, the context toolbar shows Play, Burn, Edit, Send to commands. It shouldn't since those commands are not available when the root node is selected--it should only show those commands when the subnodes are selected.
a) ii) The Auto-sync icon appears but 'Auto-sync' should appear next to it.

2 Capacity indicator:
b) The colors in the Capacity bar should be displayed in the same order as the legend i.e. Audio, Video, Other (currently it shows Other, Audio, Video)
f) If the window size is changed, the Capacity toolbar doesn't adjust appropriately in width

4 Auto-sync tab:
a) For some reason, the 'Podcast subscriptions list' appears for all Collections
g) Although the checkboxes for second-level root nodes are disabled, the fact that they exist is still confusing. Would it be a problem to just eliminate the checkboxes for these nodes ?
h) Not tested.
i) The Collections in the left-hand list should have icons (so that when we customize the Collection icons, good icons will appear for the various collections in the auto-sync list).

Ludek

2010-10-20 19:50

developer   ~0020886

Last edited: 2010-10-20 19:52

View 2 revisions

1c) OK

2.
a) OK, I disabled Play, Edit, Send to commands, but I left Burn command enabled as it was designed to be always enabled, because user can select appropriate tracks via the Burn Wizard later.

a) ii) Fixed

b) Fixed

f) Fixed

4.
a) I couldn't repro, but I guess I have already fixed it in build 1317, re-test, please.

g) The checkboxes were not there initially, but I added them based on Jiri's request otherwise user cannot see what exactly is selected, e.g. under '[] Composer' node is a composer selected and the checkbox indicates it. Another approch would be to show just 'Composer (1 item selected)', but I think that the checkboxes are better and quite user friendly and clear.
One of the reason why I tend to the checkboxes is that it looks better when user selects '[X] Hide Unselected item', then the '[x] Composer' remains visible and it looks better than 'Composer (1 item selected)' in that situation.

i) Fixed

rusty

2010-11-05 20:58

administrator   ~0021204

Tested 1321 and almost everything is fixed, except for:
4a) Every Collection still shows a 'Podcast subscriptions list' subnode

In addition, there are a few other items that I noticed:
2c) Apply button gives no feedback that it has had an effect. It should only be enabled after config changes have been made (and conversely should be disabled once changes have been applied)

2d) The options list should have a heading above it: Settings
2e) Legend (below the status bar) for 'Audio', 'Video', 'Other', 'Free', should be centered (if you expand on a widescreen monitor, the legend is left-justified)
2f) Cosmetic issue: The box containing the Collections list and the one containing the Options configuration items don't look quite right because its margins aren't even on all sides (perhaps getting rid of the left and bottom margins would solve this).

4j) Tree in the Auto-Sync list should have a heading above it: Collections
4k) If a Playlists is checked, the associated tree isn't greyed out. Moreover, and if the user expands/checks/unchecks the tree, MM can crash.

Ludek

2010-11-07 21:04

developer   ~0021226

Last edited: 2010-11-07 21:04

View 2 revisions

4a) As discussed over IM, it was caused by the fact that the 'Podcast subscriptions list' subnode was checked in the Collections -> Tree Nodes settings.
The default values are all right.

2(c,d,e,f) - Fixed in build 1323.

4j) - Fixed in build 1323.
4k) - I think that it is intended for playlists, if a parent playlist node is (un)checked then all its childred are (un)checked too. Therefore I used the same logic also for the root Playlists node. I couldn't reproduce a crash.

rusty

2010-11-08 04:46

administrator   ~0021233

Verified everything in 1323 except 4k.

Re. 4k) I don't understand what it means to check the Playlists node if the user can uncheck certain playlists, and yet the Playlists node remains checked off?!

Ludek

2010-11-08 08:06

developer   ~0021240

Fixed in build 1324.

stephen_platt

2011-02-07 20:42

developer   ~0022892

verified 1346