View Issue Details

IDProjectCategoryView StatusLast Update
0006622MediaMonkey (current)Synchronizationpublic2011-05-16 00:18
Reporterjiri 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOS7OS Version-
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006622: Synchronization configuration improvements
DescriptionThere are few areas where the new synchronization configuration could be further improved:
1. Showing of the config screen takes quite some time (like 1-2 seconds). I suppose that there isn't any obvious reason for this and in case there's necessary to do something, we can move it to a thread.

2. On the Summary sheet the device title would probably look better if not an edit line, but a label instead. It would switch to an edit line after a click, so that user could rename it.

3. Automatically unmount device appears even for devices without this capability, would better be hidden in such a case.

4. Auto-sync tab shows tree-lines in the content tree - they should be removed as they are now in the main tree.

5. The top level nodes don't seem to be at all necessary. E.g. if I select Music collection, Music node shouldn't be shown in the tree, but only its content (Location, etc.). The same for Playlists (where the issue is probably most apparent).

6. Auto-sync is the default tab on Options sheet, but it's the second, which looks a bit strange in my opinion. I'd suggest to move it to the first place (and make it the default one).

7. '(calculating)' text isn't visible behind Apply button. Also, it shouldn't be shown immediately after any action, but only in case the calculation takes >1 second. Otherwise, there's unnecessary blinking of the text.

8. To sync: sometimes shows a negative number. I suppose that it means that some content would be deleted (unless it's a bug?). I'd suggest to show '0' instead, since the negative value probably doesn't give any useful info to the user.

9. The graph showing device empty/used space is nicely clickable and nicely changes what's shown, but I'd suggest to make also Audio and Video labels clickable, in order to make it more intuitive.

10. Playlist sheet of Option tab should make more clear that Sync Playlist checkbox is necessary for all other settings of the tab. So, the other options either should be more indented, or grouped in a box.
TagsNo tags attached.
Fixed in build1325

Relationships

related to 0006490 closedLudek New Sync UI 

Activities

jiri

2010-11-01 20:39

administrator   ~0021117

Reminder sent to: rusty

Assigning to Ludek, but also sending a notification to Rusty, just in case he'd like to comment.

rusty

2010-11-07 18:54

administrator   ~0021223

Agreed on all counts.

Ludek

2010-11-08 08:48

developer   ~0021241

11) Size indicator isn't painted well when synch size exceeds device capacity.

Ludek

2010-11-08 11:12

developer   ~0021243

Last edited: 2010-11-08 11:51

View 5 revisions

1. As discussed over IM, this is most probably caused by the fact that you tested internal build with enabled memory checking that slows it down and also in my case it takes 1 second or 2, but on the standard debug build it shows immediatelly. There doesn't seem to be anything that could slow it down significantly.

2. I think that the edit line is fine, because it is intuitive that user can edit the name, but I would make the edit line disabled (not only current Read-only) for devices that haven't editable name (fixed in 1324)

3. It is hidden for devices without this capabality (like iPhone), which device you tested? It looks like a problem of a device plugin to not properly notifying the capability

7. I removed the "Calculating..." string from there and I left it only for the old-style collection size indicator, I don't think we need to show the string twice on a single screen

Issues 4, 5, 6, 8, 9, 10, 11 are all fixed in build 1324.

jiri

2010-11-09 01:49

administrator   ~0021266

2. The main point is that the edit line doesn't look good there. A label will look much better - the possibility to edit the name by clicking it is just a bonus.

3. It seems to work fine now, will try with various devices later.

7. There just remains that part of not showing it immediately, otherwise there's a lot of blinking.

12. Checking of Playlists 'collection' doesn't seem to work well - it shows that there's still '0' files. When checking individual playlists, the calculation works fine though.

13. While working with the dialog a I realized that there's too many numbers now - simply too much info to read. Since we have a nice bottom indicator of used device space, I'd suggest to remove that '0 audio files (0:00), 0 videos (0:00), 0 B'. Since this info might be useful in some cases and some users might want it, we could show it as a tooltip for each Collection.

14. The string in 13. should be simplified to not include parts with zeros - it's quite strange to select a Video collection and see '0 audio tracks, ...'. In case there isn't anything selected, we could show a special string, like 'Nothing selected.'.

Ludek

2010-11-10 15:25

developer   ~0021287

Last edited: 2010-11-10 15:27

View 2 revisions

15. Hints are shown only for some nodes (e.g. Ratings nodes are missing the hints) and the track titles should be in the form of Player Summary specified in Options -> Playback Rules.

Ludek

2010-11-10 21:03

developer   ~0021295

All is fixed in build 1324.

jiri

2010-11-11 00:26

administrator   ~0021304

All seems to work well, just:

12. Is better, but there is probably some notification problem - when checking Playlist node and unchecking it subsequently, there often remain something internally checked and tooltip of the Playlist node shows something like '250 audio files, 1 videos selected'. Also the lower graphical indicator didn't return to the correct value after just checking/unchecking the Playlist node.

Ludek

2010-11-11 12:30

developer   ~0021311

Item 12 fixed in build 1325.

stephen_platt

2011-05-16 00:18

developer   ~0025288

verified 1375