View Issue Details

IDProjectCategoryView StatusLast Update
0006979MediaMonkey (current)Synchronizationpublic2018-09-14 12:53
Reporterrusty 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006979: Incorrect defaults for MTP Device (Creative Vision)
DescriptionUpon connecting a creative Vision device, numerous defaults are incorrect:
1) Image was generic image. Surprising given that Windows displayed a correct image of the device.
2) Destination sync directories were all incorrect. I would have expected defaults that would work given that it 'just works' on WMP (e.g. MM synced to /Movies/Genre/<Title> - <Year> instead of /Video/<Title>-<Year>. Net effect is that the sync failed.
 a) shouldn't the correct destinations have been detected?
 b) should we change the default destinations so that they'll work with most devices?
3) Some of the destination directories had paths that are obviously erroneous. See attached image.
TagsNo tags attached.
Fixed in build1339

Relationships

related to 0011772 closedLudek MediaMonkey (current) Some tracks that MM mistakenly considers as duplicates fail to sync 
related to 0015096 closedLudek MediaMonkey 5 Device profile for Android devices has empty name 

Activities

rusty

2010-12-13 02:53

administrator  

jiri

2010-12-14 15:53

administrator   ~0021817

1) This wasn't ever implemented, WMDM interface doesn't give any better image than (sometimes) a small icon. Anyway, I found out how to get a hi-res image for many devices (at least on Win 7, I suppose that it's gonna work well also on Vista, probably not on XP). d_WMDM plug-in is modified now so that it returns a path to an image file (.ico) containing several resolutions of device image, from 16x16 to a hi-res image. As discussed off-line, Ludek will implement reading of the .ico file and getting the hi-res version as the device image. Also, the 16x16 could be set as a device icon for devices without one.

jiri

2010-12-15 10:28

administrator   ~0021831

2) There isn't a way how to get this info from the device, so I modified the defaults to the same paths as WMP uses, it should work fine now for all devices.
3) Remains to be fixed by Ludek, seems to be some problem in masks parsing.

Ludek

2010-12-15 10:51

developer   ~0021832

3) is fixed in 1335 by the same fix as in 0006680

jiri

2010-12-15 11:21

administrator   ~0021833

Just to clarify, the only remaining here is to finish 1).

Testing note: It's probably easiest to delete the device in Options and reconnect it, so that new defaults are applied. Alternatively, Reset Device Options button in Device config can be tested, whether it properly does its job... ;-)

Ludek

2010-12-15 14:48

developer   ~0021841

Item 1) is fixed in 1335

And yes, Reset Device Options button works to reset the defaults

jiri

2010-12-15 14:55

administrator   ~0021842

As described over IM, there are still 2 problems:
A. Even the full path gets MM path add, so instead of
C:\ProgramData\Microsoft\WPD\USB#VID_041E&PID_4150#C6A30E140002FA9D.ico
the following appears:
c:\MediaMonkey\Plugins\DeviceImages\C:\ProgramData\Microsoft\WPD\USB#VID_041E&PID_4150#C6A30E140002FA9D.ico

B. The first icon is always used from the .ico file.

Ludek

2010-12-15 19:29

developer   ~0021851

Fixed in 1335

jiri

2010-12-16 12:44

administrator   ~0021862

1) MM still doesn't load the hi-res version of the image, only some 48x48 icon (instead of about 256x256).

jiri

2010-12-16 12:44

administrator   ~0021863

Fixed in build 1335.

rusty

2010-12-17 02:35

administrator   ~0021886

Tested 1335:
1) generic image is still used, despite WMP/Windows showing hi-res graphic of the device
note: I did a clean install (i.e. uninstalled MM, and removed both /MediaMonkey directories from appdata)

2) Default sync directories are still incorrect. They are exactly as in the screencap from the previous build. Note however, that synced Music plays, however, Playlists don't sync by default, and Video/TV syncs to the wrong directories and isn't playable.

When I sync with WMP it uses the following paths:
Music: \Music\<Artist>\<Album>\
Video: \Video\
TV: \TV\

3) Verified

4) Playlists aren't enabled by default, and in the default config, don't sync to the appropriate directory (WMP syncs Playlists to: \Playlists\ ).
Note: this issue seems a bit puzzling, because as I recall, in MM3, playlists synced automatically for MTP devices (i.e. configuration was ignored). But perhaps my memory is off.

jiri

2010-12-17 09:15

administrator   ~0021892

1,2&4) All should work fine, are you sure the old DB was really deleted? Let's discuss over IM later.

Just few notes:
1) The release/debug build batch had a bug and so the version in the installer didn't work well and could actually trigger crash log generation. Fixed in build 1336.
2) I'm not sure what's the correct default for TV. I suspect that not all devices support \TV\ folder and so I rather created the default as \Video\TV\. Using device profiles we can modify this default to \TV\ for devices that we know to support TV folder. I already did this for Creative Zen X-Fi.

rusty

2010-12-19 18:14

administrator   ~0021926

Tested 1336:

1) The large images now display correctly, however, the 16x16 icon shows a generic image!

2) As can be seen in the attached image, Music and Video sync to directories that work, but other Types sync to locations that aren't read.

4) Playlists now sync

Note: If you haven't made any changes (e.g. re. 4) then it means that the bug is that device removal and/or uninstallation of MM does not delete all of the associated device settings).

rusty

2010-12-19 18:14

administrator  

vision_config.jpg (126,197 bytes)
vision_config.jpg (126,197 bytes)

Ludek

2010-12-21 15:41

developer   ~0022011

1) is fixed in build 1339

jiri

2010-12-21 16:00

administrator   ~0022013

2) These seem to be the best defaults for the devices I tested (particularly Creative Zen X-Fi, which has full video support).

4) I'm not aware of any problem, in my tests both device deletion in Options\Portable Devices or deletion of MM.DB reverted to defaults (not to mention Reset Settings button in device config dialog).

rusty

2010-12-21 17:52

administrator   ~0022017

Note: tested 3 and 4 in 1338, and they work correctly. There is a minor problem with the Zen (see below), but that can only be fixed with a custom profile.

Video Podcast: Shows up in subfolder to video (rather than in Zencast folder), but plays correctly
V: Shows up in subfolder to video (rather than TV folder), plays correctly

peke

2013-12-07 05:01

developer   ~0038568

Verified 1675