View Issue Details

IDProjectCategoryView StatusLast Update
0006680MediaMonkey (current)Properties/Auto-Toolspublic2011-07-24 20:13
Reporterjiri 
PriorityurgentSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006680: Introduce new masks for new fields
DescriptionCurrently we have masks for new fields only as aliases (e.g. <Series> means the same as <Album>). This results in several problems, e.g. we don't know which one to show - in Options/Playback rules/Video we have <Album> mask used, even though this field doesn't make sense there and should be <Series> instead.

1. So, we should have a non-alias mask for each new field (e.g. Album=%L, but Series will be %{something else}). Note that even after this change, both masks actually refer to the same field, so they return the same text. But thanks to this change they are distinguishable.
2. These new masks should be properly used on several places (like above mentioned Playback rules).
3. That [>>] button used for masks (e.g. Auto-organize dialog) should be improved, so that it dynamically shows only applicable masks, i.e.:
 3a. <Album> mask should be shown only if the dialog is opened with >=1 track with Type=[Music, Music Video, Audiobook] (+something else?)
 3b. <Series> mask should be shown only if the dialog is opened with >1 file with Type=[Video, TV]
TagsNo tags attached.
Fixed in build1409

Relationships

parent of 0008184 closedLudek Auto Organize Drops Leading Zero (regression) 
related to 0006934 resolvedLudek Not all metadata values are available for Masks in Auto-Tools 

Activities

Ludek

2010-11-11 18:28

developer   ~0021316

Last edited: 2010-11-11 22:40

View 6 revisions

This new masks: <Podcast>, <Series>, <Producer>, <Director>, <Episode#>, <Season#>
added in build 1325.

Note that the current assignment rules are:
Album = Podcast = Series
Composer = Producer
Conductor = Director
Track# = Episode#
Disc# = Season#

Ludek

2010-11-11 22:41

developer   ~0021321

Re-opened, because I forgot to implement item 3)

Ludek

2010-11-12 14:46

developer   ~0021324

Implemented in build 1325.

rusty

2010-12-09 05:10

administrator   ~0021696

Tested (not comprehensively) in 1332. Noticed a couple of issues:
a) Season # is missing for TV tracks
b) A field called ZZA is displayed when clicking >> for TV/Video tracks

Ludek

2010-12-09 13:47

developer   ~0021699

c) <Director> was mapped to Conductor instead of Artist internally

All is fixed in build 1333

peke

2010-12-14 03:41

developer   ~0021807

When reopening auto tag from filename and active mask contained <Episode#> on re opening it is translated to %ZY

Filename: Lost.Girl.S01E13.HDTV.XviD-2HD.avi
Mask: <Title>.S<Season#:2>E<Episode:2>.<Skip>-<Publisher>

Mask on next Auto Tag From Filename: <Title>.S<Season#:2>E%ZY.<Skip>-<Publisher>

Ludek

2010-12-14 14:35

developer  

auto-tag.JPG (52,142 bytes)
auto-tag.JPG (52,142 bytes)

Ludek

2010-12-14 14:57

developer   ~0021814

Fixed in 1335

peke

2011-01-12 23:57

developer   ~0022333

verified 1343

lowlander

2011-07-04 19:37

developer   ~0026519

Last edited: 2011-07-04 19:37

View 2 revisions

<Season#:2> and <Episode#:2> fail with Auto-Organize Files to create 2 digits in filename.

Ticket ID: MIQ-991392

Ludek

2011-07-05 13:27

developer   ~0026534

Fixed in build 1401.

lowlander

2011-07-14 15:39

developer   ~0026802

<Season#:2> and <Episode#:2> add leading space and not a leading 0 on 1407.

Ludek

2011-07-15 12:16

developer   ~0026851

Fixed in build 1408.

lowlander

2011-07-15 17:19

developer   ~0026859

<Season#:2> and <Episode#:2> works on 1408, but <Season#> and <Episode#> also force leading 0.

Ludek

2011-07-15 20:02

developer   ~0026866

Yes, this is consistent with <Track#>

lowlander

2011-07-15 20:20

developer   ~0026867

That's not true <Track#> gives a single digit in filename when it is single digit, whereas <Season#> gives double digit in filename when it is single digit. <Track#> has always been single digit and still is.

Ludek

2011-07-15 21:24

developer   ~0026870

You are right, I somehow mistested it before.

Fixed in build 1409.

lowlander

2011-07-24 20:13

developer   ~0026972

Verified in 1411