View Issue Details

IDProjectCategoryView StatusLast Update
0006447MediaMonkey (current)Codecpublic2011-05-28 23:54
Reporterpeke 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionsuspended 
Product Version3.2.2 
Target VersionFixed in Version4.0 
Summary0006447: 6ch FLAC and WAVs are not playable in MM
Description6 Chanel FLAC and WAVE files are not playable in MM even Format plugin reads them correctly.

Sample files will be uploaded to FTP.
Additional Informationhttp://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=9538
http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=10087
http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=52147
http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=11429&departmentid=2&ticketstatusid=4
TagsNo tags attached.
Fixed in build1379

Relationships

related to 0003362 closedmichal Support multichannel tracks 
related to 0006477 closedmichal WMA: Multichannel WMA are decoded as Stereo 
related to 0006478 closedmichal OGG: Multichannel OGG file Crashes MM 
related to 0006609 closedmichal Bad handling of multichannel audio, especially in conversions 
related to 0006635 closedmichal out_wave plugin cannot play multichannel audio in Windows 7 

Activities

michal

2010-08-24 18:01

developer   ~0020457

I found out, that this issue is probably related to all 24bit 6ch sound files, not only FLAC and WAV. I reproduced the problem only in Windows 7 64b, in XP everything seems to be ok. The problem is in output plugins - out_MMDS and out_wave, both give error "invalid parameter" when creating sound buffer (WaveOutOpen, CreateSoundBuffer), I have no idea why and why in XP not. Peke, could you do more research, please?
WASAPI output plugin plays these files correctly...

peke

2010-08-24 21:25

developer   ~0020458

Maiko WASAPI plugin play only two chanels and report that ">2" error, but have found that old winamps out_ds plays them without problems (the one we used in MM).

I uploaded out_ds to ftp.

jiri

2010-09-08 01:23

administrator   ~0020492

Peke, since Michal has a lot of other stuff to work on, please look into out_DS plug-in sources and try to find out, how to call the initialization so that it doesn't fail.

Note, that this issue will also be fixed by fixing 0006469, but it would be nice to have this one fixed anyway.

peke

2010-09-10 03:07

developer   ~0020518

As talked over IM WAVE_FORMAT_PCM do not support Multi channel and out_MMDS needs to use IDirectSound8 instead of IDirectSound along with WAVE_FORMAT_EXTENSIBLE packed record to allocate buffers correctly.

Will see if there is way for easy fix.

peke

2010-09-14 00:37

developer   ~0020522

Last edited: 2010-09-14 00:44

View 2 revisions

Uploaded Smaller WAV and FLAC samples

Ludek

2010-09-16 13:07

developer   ~0020532

Last edited: 2010-09-16 13:17

View 3 revisions

Tested in Win XP and there is no problem playing 6 channel FLACs and WAVs by using out_MMDS.dll output plugin.

michal

2010-11-03 08:15

developer   ~0021143

Out_wave plugin fixed in build 1321.

peke

2010-11-06 23:30

developer   ~0021211

Out_wave verified 1322

have you received sources/changes for out_mmds?

michal

2010-11-07 07:52

developer   ~0021212

peke: yes, I do. It does not play 6ch audio in Win7 and has buggy playback in XP. I have no time for debug now, other things have higher priority, will see later.

peke

2010-11-07 09:50

developer   ~0021213

Certainly, for now out_wave works as it should, I know it is buggy but I was just starting to rewrite (See System Folder in sources).

I wonder if we should open new ticket due the fact that original bug issue is solved with out_wave?

peke

2010-12-20 21:07

developer   ~0021976

Cleared 4.0 target for now.

michal

2011-05-23 17:16

developer   ~0025576

out_MMDS fixed in build 1379.

peke

2011-05-28 23:54

developer   ~0025739

Verified 1381