View Issue Details

IDProjectCategoryView StatusLast Update
0006469MediaMonkey (current)Playerpublic2019-10-02 10:06
Reporterjiri 
PriorityurgentSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0006469: Make WASAPI output plug-in default, with a fall-back to DS
DescriptionSince WASAPI plug-in currently replaces all the DS plug-in functionality, we should make it the default. In case it doesn't work (e.g. for Win XP), it should be automatically switched to out_DS.dll.
Additional InformationThe automatic switch to out_DS should happen in the main application (WinampPlugins.pas) whenever a call to Open() function of out_WASAPI fails. It should be hardcoded to out_DS.dll.
TagsNo tags attached.
Fixed in build1383

Relationships

related to 0006553 closedLudek MediaMonkey (current) out_WASAPI Not included in installation 
related to 0006702 closedjiri MediaMonkey (current) WASAPI output plugin stutters 
related to 0014326 assigned MediaMonkey 5 WASAPI/DirectSound: Device Change issue and Auto Playback resume feature 

Activities

Ludek

2010-09-13 13:47

developer   ~0020520

Implemented in build 1312.

BUT, on WinXP I left 'out_MMDS.dll' as default output plugin, because XP users would be confused how it is possible that WASAPI doesn't fail on XP and silently switches to out_MMDS.
e.g. They would configure WASAPI to Crossfade 5 seconds, but in fact the out_MMDS would be used. This would be very confusing.
Therefore also the hardcoded fall-back is performed only on Vista and higher Win versions.

peke

2010-12-12 06:02

developer   ~0021766

Verified 1334

lowlander

2011-01-31 04:13

developer   ~0022711

XP users can currently enable WASAPI and nothing will play. It shouldn't be selectable if it doesn't work. http://www.mediamonkey.com/forum/viewtopic.php?p=285035#p285035

Ludek

2011-01-31 12:55

developer   ~0022717

Last edited: 2011-01-31 12:56

View 2 revisions

Fixed in build 1346,
the wasapi plugin node is now disabled on Win XP and lower

lowlander

2011-02-01 16:13

developer   ~0022777

Verified in 1346

jiri

2011-05-31 15:15

administrator   ~0025795

As discussed offline, we should revert this fix. I.e. to make out_MMDS the default output plug-in and also to not use out_MMDS in case out_WASAPI fails.

This is part of remedy re. 0007327.

Ludek

2011-06-01 12:18

developer   ~0025829

Reverted in build 1383.

peke

2011-07-20 00:27

developer   ~0026928

Verified 1410