View Issue Details

IDProjectCategoryView StatusLast Update
0003362MediaMonkey (current)Playerpublic2011-08-09 01:11
Reporterjiri 
PriorityurgentSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version3.0 
Target VersionFixed in Version4.0 
Summary0003362: Support multichannel tracks
DescriptionCurrently we don't support well multichannel tracks, e.g. 5+1 channel tracks aren't properly recognized (i.e. shown correct number of channels) and there are possibly even problems with playback (to be tested).

Examples in various formats are uploaded to FTP.
TagsNo tags attached.
Fixed in build1381

Relationships

related to 0006477 closedmichal WMA: Multichannel WMA are decoded as Stereo 
related to 0006478 closedmichal OGG: Multichannel OGG file Crashes MM 
parent of 0007884 assignedmichal Downmixing more than 2 channels to 2 channels discards channels 
related to 0006609 closedmichal Bad handling of multichannel audio, especially in conversions 
related to 0006447 closedmichal 6ch FLAC and WAVs are not playable in MM 
Not all the children of this issue are yet resolved or closed.

Activities

jiri

2007-08-04 15:30

administrator   ~0010060

Assigning to Pavel to fix as much as possible, mainly support of AAC and possibly even OGG. Let me know should there be any things to be fixed on my side.

jiri

2010-10-29 23:26

administrator   ~0021073

Michal, please review how much still needs to be resolved here.

michal

2011-05-20 09:00

developer   ~0025513

5.1 channels are recognized properly.
1) There is a problem with conversions - covered by issue 0006609
2) Playback using out_MMDS does not work in Win7 - covered by 0006447
3) WASAPI output plugin plays only 2 channels and discards the rest. This is probably problem with downmixing procedure, the same behaviour occures with converting 6ch video to 2ch (the same downmixing procedure). The procedure should be improved to mix channels, not discard.
4) There is a problem with AAC 5.1 playback, MM does not play the sample file. It is because in_mfaudio fails to play it. Without in_mfaudio.dll, MM plays the file using QT.

michal

2011-05-20 11:10

developer   ~0025514

4) fixed in build 1378.

michal

2011-05-26 17:44

developer   ~0025664

All should be fixed in build 1381. I've inserted mixing issue (3) separately as 0007884

peke

2011-08-09 01:11

developer   ~0027110

Verified 1415