View Issue Details

IDProjectCategoryView StatusLast Update
0013345MediaMonkey for AndroidPlaybackpublic2017-07-28 18:54
Reporterpeke 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionsuspended 
Product Version1.2.0 
Target Version1.3.0Fixed in Version 
Summary0013345: Equalizer: Not working correctly without headphones connected
DescriptionEQ on Alcatel OneTouch Idol 3 MM 6.0.1 do not work correctly and dissort sound from speakers.

When headphones are connected EQ works as it should.
TagsNo tags attached.
Fixed in build

Relationships

related to 0011746 feedbackmartin (Bluetooth) playback is corrupted when equalizer is enabled on some devices 
related to 0011907 assignedmartin Replace equalizer with 10-band equalizer 
has duplicate 0014314 resolvedmartin EQ: Using EQ over BT issues 

Activities

peke

2016-06-08 21:37

developer   ~0044899

Alcatel Music and MIX EQ works without any problems.

rusty

2017-03-07 03:03

administrator   ~0047414

I'm able to replicate this on an S7 as well by enabling the equalizer and switching between Max and Min values.

The problem doesn't occur with the headphones plugged in.

rusty

2017-06-08 15:19

administrator   ~0048098

Generated a debug log with an S7.
1 Played 'What do you mean'
2 Enabled equalizer and switched to 'Flat'
3 Raised 14000 Khz to 14DB
--> volume reduced!
4 'Reset' to default flat settings
--> volume increased!

Debug log: MMQKKRYUS3

martin

2017-06-14 07:11

developer   ~0048136

Last edited: 2017-06-14 15:49

View 2 revisions

These issues are another reason why we plan to use another equalizer implementation 0011907.
Mainly Samsung (and some other OEMs e.g. Asus) devices has issue with the subtractive equalizer provided by Android system.
Discussion about it e.g here:
https://forums.androidcentral.com/samsung-galaxy-s5/383015-galaxy-s5-music-equalizer-not-working-properly-lowers-song-volume-when-raise-band-levers.html
I can also replicate it on Samsung S3Mini only.

Also issue from speakers is not on MMA side, because there is no difference in implementation.

I hope these issues will be fixed by 0011907.