View Issue Details

IDProjectCategoryView StatusLast Update
0009423MediaMonkey 4Install/Configpublic2013-02-26 21:21
Reporterlowlander Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0.6 
Target Version4.1Fixed in Version4.1 
Summary0009423: Portable isn't fully Portable
Description1) Install MediaMonkey as portable in C:\Software\MediaMonkey, start MediaMonkey, close MediaMonkey.

2) Then rename folder to C:\Software\zzzzz, start MediaMonkey.

Notice that C:\Software\MediaMonkey is recreated with Portable folder containing Previews and VirtualCD. Checking Settings the Temp folder points correctly to zzzzz, but the UPnP Cache folder doesn't.
Steps To ReproducePaths from ini:
WinampPath=C:\Program Files\WinAmp\WinAmp.exe
TempDir=C:\Software\zzzz\Portable\Temp\
CacheDir=C:\Software\MediaMonkey\Portable\VirtualCD\
PreviewDir=C:\Software\MediaMonkey\Portable\Previews\
UPNP_CacheDir=C:\Software\MediaMonkey\Portable\Temp\Transcoded_Media_Files
[PodcastMasks]
Mask1=C:\Software\zzzz\Portable\Podcasts\%L\%S
Mask2=C:\Software\MediaMonkey\Portable\Podcasts\%L\%S
[DownloadMasks]
Mask1=C:\Software\MediaMonkey\Portable\Downloads\%A\%L\%S
Additional InformationNote that WinAmp Path is pointing to non-existing location. Other users of forum have noted issues with Portable and drive letters, I haven't actually moved the Portable to different PC's (it's installed on local hdd).
TagsNo tags attached.
Fixed in build1625

Relationships

related to 0008182 closedpeke Last.fm plugin Portable mode: OS integration settings aren't saved and some plugins fail (MM Com Server not registered) 
related to 0009647 assignedLudek MediaMonkey 4 Paths are stored with drive letter instead of driveID in Folder Monitoring (Add/Rescan Files) 

Activities

lowlander

2012-06-12 15:25

developer   ~0031353

http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=66416

lowlander

2012-06-19 17:01

developer   ~0031401

Last edited: 2012-06-19 17:02

View 2 revisions

Custom downloads and Podcasts folders are also reset to default values after restart: http://www.mediamonkey.com/forum/viewtopic.php?f=7&t=66581

rusty

2012-06-21 15:34

administrator   ~0031436

Last edited: 2012-06-21 16:16

View 3 revisions

Note: the Virtual CD and Preview functionality can trigger error messages in MM portable, if the path to the VCD is not available when the portable drive is installed in a new machine:

“The directory H:\[…]\Portable\VirtualCD cannot be created”
“The directory H:\[…]\Portable\Previews cannot be created”

raised priority due to the error that results.

rusty

2012-06-21 17:51

administrator   ~0031440

Last edited: 2012-06-21 17:52

View 3 revisions

Note that by default, MM sets most path configs to an absolute path on the portable drive. The problems therefore result when the portable drive is installed on a different machine that assigns a different drive letter to the USB drive.

The solution is to support relative paths in the .ini file.

petr

2012-06-21 18:47

developer   ~0031441

Fixed in 1499

rusty

2012-06-22 04:11

administrator   ~0031448

This isn't quite fixed. Issues discovered after doing a clean portable install:
1) All paths in the config are still absolute paths (e.g. K:\My Documents\VirtualCD)
2) When unplugging the USB key containing MM from PC A (where it is drive K:) to PC B (where it is drive I) --> error results re. USB drive AND Access Violation results.

petr

2012-06-22 08:22

developer   ~0031452

Fixed in 1499.

rusty

2012-06-22 14:27

administrator   ~0031454

Verified 1499. Note that the paths are stored relatively, but display as absolute paths in the configuration screens.

lowlander

2012-08-20 19:30

developer   ~0031666

UPnP cache folder is shown as relative Path in Options. This seems to result in UPnP playback failing to play files that require conversion until path is corrected.

lowlander

2012-11-09 16:46

developer   ~0033036

Podcast folder is still being reset on 1509.

lowlander

2013-02-02 18:10

developer   ~0034747

On 1623 Podcasts/Downloads/Temp folder all reset after start. Even setting correct drive/folder in ini has it reset on start of MediaMonkey.

petr

2013-02-06 00:00

developer   ~0034810

Fixed in 1624

lowlander

2013-02-12 16:53

developer   ~0034863

On 1624 user modified Downloads and Podcasts folder is remembered, but the General Temp folder is not.

Ludek

2013-02-15 11:47

developer   ~0034953

Last edited: 2013-02-15 12:08

View 4 revisions

Fixed in build 1625 although I don't think it is good to make Podcasts/Downloads folders configurable in portable mode, because if anyone change them to another drive then they are no longer portable.
It will be harder for our support team to troubleshoot such issues.

lowlander

2013-02-26 21:21

developer   ~0035131

Verified on 1625 that general temp folder also remembers user changes.