View Issue Details

IDProjectCategoryView StatusLast Update
0009421MediaMonkey 4Burning / Disc Handlingpublic2022-04-29 01:04
ReporterLudek Assigned To 
PriorityhighSeverityminorReproducibilityunable to reproduce
Status resolvedResolutionnot fixable 
Product Version4.0.5 
Target Version4.0.7Fixed in Version4.0.6 
Summary0009421: Ripping fails for some users when 'Secure read' mode is selected (regression on x64)
DescriptionSome users reported that ripping in secure mode fails with 4.0.5.1496.
One user reported that last working build is 4.0.5.1488

It is strange as there wasn't any disc handling change in build 1489, the only changes were in build 1480 only when 'Verify ripped tracks' is enabled.
But user confirmed the failure happens even when 'Verify ripped tracks' is disabled. And that he is 100% sure that last working build is 1488.
The only that could have an impact seems to be 0009326 ?
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=1&t=66388
http://www.mediamonkey.com/forum/viewtopic.php?f=7&t=66426#p340624
SNB-368971
TagsNo tags attached.
Fixed in build1498

Relationships

related to 0009202 closedLudek MediaMonkey 4 Rip verification fails when 'Jitter corrected read' is selected 
related to 0009199 closedLudek MediaMonkey 4 Files ripped with "Verify ripped tracks" option have some strange extra bytes apended to the data 
related to 0009326 closedpetr MediaMonkey 4 MM Observes x86 2GB RAM usage limit 
related to 0009673 resolvedpeke MediaMonkey 4 AccurateRip: Verification results incorrect? 
related to 0009710 closedLudek MediaMonkey 4 Failure to rip the last track of a CD (Secure Read mode) 
related to 0013284 closedLudek MediaMonkey 4 RIP: Blue-screen-of-death when Secure Ripping audio CDs to flac 
related to 0017267 closedLudek MediaMonkey 5 Crash while ripping: 166D0000 

Activities

Ludek

2012-06-11 18:55

developer   ~0031348

Last edited: 2012-06-11 18:55

View 2 revisions

It is due to 0009326 as confirmed here: http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=66388&p=340793#p340792

Ludek

2012-06-12 16:36

developer   ~0031355

Peke, Stephen and Rusty confirmed no problems when ripping in secure mode.

We confirmed with the user here:
http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=66388&p=340884#p340883 [^]
that the problem doesn't appear for him when size of read buffer is the same as in case of standerd read (63 KB) then it works fine, but if it is 512 KB or bigger (like in case of secure read) then it fails. So the solution is reduce size of read buffers in case of secure reading.

Ludek

2012-06-13 19:15

developer   ~0031367

Fixed in build 1498.

Ludek

2012-06-20 10:30

developer   ~0031402

Last edited: 2012-06-20 16:44

View 2 revisions

There is one user for who it still fails on Vista x64 although the read buffers in secure mode are same as in the standard read mode. Solving via ticket ID: FGM-971451

Ludek

2012-06-21 08:34

developer   ~0031425

Last edited: 2012-06-21 08:54

View 5 revisions

I am waiting for the user reply, but it is a low level problem and it looks that we cannot do much about it. We should add KB article for users experiencing this problem

1. Ensure that the drive firmware is up-to-date
2. Try switch Rip Type from 'Secure read' to 'Standard read'
3. If 1&2 doesn't help then use "CFF Explorer.exe" in the section 'File Header' and DISABLE the checkbox "App can handle > 2GB address space" for MediaMonkey.exe and MediaMonkey (non-skinned).exe

Re 3) See screenshots here: http://www.ls-uk.info/forum/index.php?topic=54930.0

rusty

2012-06-21 14:50

administrator   ~0031432

KB is updated at http://www.mediamonkey.com/support/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=43

Ludek

2015-02-05 16:04

developer   ~0041971

Current KB link is http://www.mediamonkey.com/support/index.php?/Knowledgebase/Article/View/42/0/audio-cds-fail-to-scan-play-or-rip-correctly