View Issue Details

IDProjectCategoryView StatusLast Update
0009316MediaMonkey 4Synchronizationpublic2012-05-07 22:06
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version4.0.5 
Target Version4.0.5Fixed in Version4.0.5 
Summary0009316: Playlists fail to delete in some cases from iOS5 device
DescriptionUpon upgrading from 1485 to 1486, playlists that had been created with 1485 failed to delete with 1486 (Delete files and playlists not included in Auto-sync.... was enabled).

Note: tracks did delete as expected.
TagsNo tags attached.
Fixed in build1489

Relationships

parent of 0009390 closedLudek Playlists can be shown twice on non-iOS devices like iPod Nano after upgrade from 4.0.3 
related to 0009317 closedLudek iOS5: Playlists created in iPhone doesn't show in MediaMonkey interface 
related to 0009294 closedLudek iOS device can be identified incorrectly in the tree 
related to 0009357 closedLudek iOS playlist sync problems 

Activities

Ludek

2012-05-03 13:42

developer  

Sync.png (31,414 bytes)   
Sync.png (31,414 bytes)   

Ludek

2012-05-03 13:45

developer   ~0031002

@Rusty, I cannot replicate the issue.
1. I added 1 playlist called "Sync" including 1 file on the sync-list and synced the device.
2. Verified that the playlist and the file are in the device
3. Unchecked the playlist and re-synced
4. The table on the attached screenshot appeared and suggested to remove both the track and the playlist
5. Clicked [Continue]
=> Both the track and the playlist are deleted

What are your steps?

Ludek

2012-05-03 13:55

developer   ~0031003

BTW: in the course of testing this I found another issue: 0009317 , maybe it is releated in order to reproduce this?

Ludek

2012-05-03 15:23

developer   ~0031006

Finally I found steps to repro, you must rename the playlist in MM. Was this your case?

Fixed in build 1487.

rusty

2012-05-03 16:32

administrator   ~0031009

It wasn't my repro step--I'd just synced some playlists/podcast/videos with 1484, and then did a clean install of 1485 and synced some other tracks/playlists/podcasts/videos and observed the problem. No matter how many times I sync, those playlists don't get removed.

I'll leave the iPod in it's current state and test whether your fix resolves the problem and deletes the Playlists that aren't getting deleted.

rusty

2012-05-04 20:40

administrator   ~0031023

Tested 1487, and whenever I connect MM it shows only 2 playlists no the device. But when I look at the device itself, it shows 4 playlists (2 of which contain 0 tracks).

When I sync with MM, it fails to delete those 2 playlists (likely because it doesn't 'see' them).

When I connect the device to iTunes (no sync / no playback), it shows 2 playlists, however, if I subsequently look at the device in MM, no playlists display! But if I subsequently look at the playlists on the device, all 4 appear!

Ludek

2012-05-04 21:27

developer   ~0031024

Last edited: 2012-05-04 21:29

View 2 revisions

Is your iTunes config:
[ ] Open iTunes when this iPod is connected
[x] Manually manage music and videos
i.e. the first needs to be checked and the second unchecked

I don't think it is a good idea to test builds previous to 1487. I would recommend to test just the newest build and clean everything from the iPhone before reproducing an issue. SO that we are sure thet the issue is not affected by previous test builds.

Re the iTunes: Sure, iTunes can write whatever it wants to the device, but if you have the two checkboxes in the proper state then iTunes doesn't touch the iTouch (at least based on my experiance).

rusty

2012-05-06 02:21

administrator   ~0031030

iTunes is configured as you described, and MM was tested only with build 1487, though it wasn't 'cleaned' by deleting everything from the device and syncing a single track beforehand. 'Cleaning' it by syncing a single track with iTunes is an unrealistic requirement--MM should be able to 'clean' it in the same manner that syncing with iTunes does.

As far as iTunes not doing anything to a device configured as described, iTunes _does_ seem to be doing something to the device when it is plugged in as evidenced here: http://screencast.com/t/FdtiF1OPWM (plugging in the device with iTunes running triggers a change on the device that causes MediaMonkey to 'lose' it's record of the device name).

Ludek

2012-05-07 16:02

developer   ~0031040

Last edited: 2012-05-07 18:03

View 2 revisions

I have reproduced the issue.

1. Sync a playlist using MM
=> playlist is visible in MM and the Device
2. Run and close iTunes
=> playlist is visible in iTunes and the Device, but isn't visible in MediaMonkey

This can cause subsequent problems of failed playlist deletion as MM "does not know" about the playlists.

Another subsequent problem is that playlists synced by iTunes are not visible in MM.

All is fixed in build 1488.

Ludek

2012-05-07 22:06

developer   ~0031044

Last edited: 2012-05-07 22:07

View 2 revisions

BTW. I found some other issues with Playlists deletion (not consistently reproducable).

Fixed in build 1489.