View Issue Details

IDProjectCategoryView StatusLast Update
0008476MediaMonkey 4Properties/Auto-Toolspublic2012-02-01 04:04
Reporterrusty Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0.3Fixed in Version4.0.3 
Summary0008476: Issues re. first run in Elevated mode (D&D problems, etc)
DescriptionWhen MM is run in elevated mode (e.g. on first run, or upon configuration changes to the OS integration panel), attempts to drag and drop artwork / tracks fails.

e.g. drag image from firefox onto the Art & Details window
--> 'Do not enter' symbol appears by the cursor instead of the 'copy' symbol
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=60534
Tagstodoc
Fixed in build1465

Relationships

related to 0008142 closedLudek Installation via non-admin user --> failed OS integration 
parent of 0008943 closedpetr MM continually prompts for elevation on Standard user account / uses admin settings db (regression) 

Activities

Ludek

2011-10-05 21:31

developer   ~0028078

Last edited: 2011-10-05 21:41

View 7 revisions

I am afraid that we cannot do anything about this, based on links like
http://superuser.com/questions/59051/drag-and-drop-file-into-application-under-run-as-administrator
http://social.msdn.microsoft.com/Forums/en-US/windowsgeneraldevelopmentissues/thread/72f35f33-2df0-47e8-a16d-006f1190d81e
http://forums.winamp.com/showthread.php?t=316479
this is problem with any program.

The problem is tied to how security permissions work. The ability to drag and drop from a normal applications to an elevated one would break the security model behind UAC.

I guess we should compose KB article based on tips from here:
http://superuser.com/questions/59051/drag-and-drop-file-into-application-under-run-as-administrator

rusty

2011-10-05 22:17

administrator   ~0028081

I suppose the only 'fix' would be to not run MM in elevated mode after changes are made to the config, but rather to quickly run an elevated config process, after MM has been closed to take care of config changes.

peke

2011-10-11 10:29

developer   ~0028178

Last edited: 2011-10-11 10:30

View 2 revisions

I'm not sure if we can make small APP that will start in Elevated Mode to do config (after install for example) and start MM in non elevated mode while app will wait for MM to finish settings or Add command switch to start that small app in Elevated mode after user Click OK in OS integration Panel?

Guess it is something for MM 4.1

rusty

2012-01-10 18:10

administrator   ~0029796

Last edited: 2012-01-10 21:49

View 2 revisions

Another problem reported is that even in portable mode, MM is forced to run 'Elevated' the first time it is run (which shouldn't happen since there aren't/shouldn't be any system changes in portable mode).

Summary:
The current approach of forcing MM elevate:
- the first time it is run
- on any run subsequent to making config changes
is problematic for several reasons:

1) it's confusing in normal scenarios (i.e. why is MM running elevated)
2) it breaks d&d for the duration of that session
3) it triggers re-elevation issues for users that install as Admin but run MM as standard user (see 0008943)
4) it triggers elevation in portable mode which shouldn't happen.

From a user's perspective, the app should never run elevated except when:
a) installing the app
b) upon making config changes that require elevation (e.g. spawn a separate elevated process)

Assigning to Jiri for feedback re. 4.0.3.

jiri

2012-01-11 08:41

administrator   ~0029815

This will be fixed by fixing 0008943.

petr

2012-01-18 23:52

developer   ~0029956

Fixed in 1465

peke

2012-02-01 04:04

developer   ~0030178

Verified 1466