View Issue Details

IDProjectCategoryView StatusLast Update
0008386MediaMonkey 4Properties/Auto-Toolspublic2011-10-14 20:28
Reporterlowlander Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0008386: <Type> causes next mask to fail in Auto-Organize Files
DescriptionUsing <Type will cause the next mask to field. For example <Genre> ends up as Genre in filename and not the Genre value.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=60533
TagsNo tags attached.
Fixed in build1434

Relationships

related to 0008112 closedLudek Parental Rating is missing from Auto-Tag from Filename and Auto-Organize (Files) 
related to 0007330 closedLudek Auto-tag from filename: Series, Director, Producer in mask doesn't work 
related to 0008375 closedpetr Using $) in mask doesn't work as expected (regression) 

Activities

rusty

2011-09-16 02:49

administrator   ~0027759

Note: according to LL, the same problem occurs with Parental Rating--i.e. fields that are unsupported cause valid fields that follow the unsupported field in the mask, to be ignored.

Ludek

2011-09-18 22:13

developer   ~0027825

Fixed in build 1434.

stephen_platt

2011-09-21 15:34

developer   ~0027884

verified 1434

lowlander

2011-10-14 20:13

developer   ~0028283

On 1445 this still happens with <Parental Rating>

Mask: <Title> [<Language>-<Year>-<Parental Rating>-<Skip>-<FreeDB>]\<Skip>
Filename: G:\Movies\TV\101 Dalmatians [English-1961-G-MPG-tt0055254]\101 Dalmatians.mpg

Will give Title and Language (Custom1) as expected, but all files will get Year as 2000 despite no 2000 being present in folder/filename and FreeDB (Custom4) is skipped altogether.

Mask: <Title> [<Language>-<Year>-<Skip>-<Skip>-<FreeDB>]\<Skip>
works as expected.

Fixing 0008112 would also resolve the issue.

Ludek

2011-10-14 20:21

developer   ~0028284

Last edited: 2011-10-14 20:28

View 3 revisions

This seems to be unrelated to this issue. You are rather talking about "Auto-tag from filename" feature (this really belongs to 0008112).

This issue is about "Auto-Organize Files", i.e. inverse process.

In addition using '<Title> [<Language>-<Year>-<Skip>-<Skip>-<FreeDB>]' on filename 'G:\Movies\TV\101 Dalmatians [English-1961-G-MPG-tt0055254]\101 Dalmatians.mpg'
correctly gets year 1961 for me. I also added it to automated DUnit regression tests.