View Issue Details

IDProjectCategoryView StatusLast Update
0008121MediaMonkey (current)Properties/Auto-Toolspublic2011-09-13 00:15
Reporterlowlander 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0008121: File Monitor fails to pick up Art
DescriptionWith MediaMonkey set to scan file directories for Art the File Monitor can fail to pick up art in the folder.
Steps To Reproduce1) Create a new folder in a monitored folder
2) Add an image and name it folder.jpg in the new folder
3) Add a file (tested with MPG) to the new folder
4) Notice that File Monitor picks up the new file, but doesn't associate artwork with it
5) Run Add/Rescan Files on same folder
6) Artwork is now associated
TagsNo tags attached.
Fixed in build1416

Relationships

related to 0007060 closedpetr Thumbnail generation/display for Home Videos is problematic 
related to 0008203 closedLudek File monitor adds cover files also when 'Scan file directories for Artwork' is disabled (regression) 
related to 0008360 closedjiri Regressions in artwork handling 
related to 0007780 closedLudek Images in podcast folders aren't assigned to Podcasts on download 

Activities

Ludek

2011-07-13 10:20

developer   ~0026757

Fixed in build 1407.

lowlander

2011-07-15 17:57

developer   ~0026862

Last edited: 2011-07-15 18:01

View 2 revisions

I tested with 3 movies and with all 3 the File Monitor failed to pick up the art. For 2 of the 3 Add/Rescan Files also failed to pick up art. This Add/Rescan Files failure might be attributed by the lack of tags in the file.

It seems that:
File Monitor > Fails
File Monitor > Add/Rescan Files (no tags) > Fails
File Monitor > Add/Rescan Files (tags) > works
File Monitor > Remove file from Library > Add/Rescan Files (no tags) > works

Ludek

2011-07-15 20:38

developer   ~0026868

Last edited: 2011-07-15 20:53

View 5 revisions

I see in the log that several folder.jpg images were imported correctly.
Note that both Add/Rescan and File Monitor uses the same procedure so there shouldn't be a difference.

Please ensure that the JPGs match all rules specified in 0007060
Especially check
1. For folder.jpg - whether all videos in folder are from same series or there's just one video file.
2. For other image filenames - whether cover name is same or very similar to video name.

I added some new debug messages in build 1409 so that I could see this from the debug log.

Ludek

2011-07-15 21:12

developer   ~0026869

I re-checked the code and you are right, File Monitor still fails to pick up the art.

Ludek

2011-07-15 22:12

developer   ~0026871

Fixed in build 1409.

lowlander

2011-07-15 22:28

developer   ~0026872

PS. there is a single image in the folder named folder.jpg, a single MPG file get's added and this file has no tags (ie no Series, Director, ect.)

Ludek

2011-08-10 20:12

developer   ~0027163

Re-opened, because:

This works if you copy the track and then the image.
It fails if you copy the image first and then the track.

Ludek

2011-08-11 10:49

developer   ~0027170

Fixed in build 1416.

peke

2011-09-10 23:29

developer   ~0027581

Tested with 1430 and in some cases File monitor fail to detect adding folder.jpg on folder that already contain tracks in MM library and update their Art.

Reverse order 2.<->3. of original steps:
1) Create a new folder in a monitored folder
2) Add a file (tested with MPG) to the new folder
3) Add an image and name it folder.jpg in the new folder
4) Notice that File Monitor picks up the new file, but doesn't associate artwork with it
5) Run Add/Rescan Files on same folder
6) Artwork is now associated

Ludek

2011-09-12 11:32

developer   ~0027599

Last edited: 2011-09-12 11:42

View 2 revisions

I cannot reproduce,

A) It could be just a consequence of 0008360, i.e. isn't it just a refresh issue?
B) Are the video files all from the same series? i.e. Does this happen if you copy only one MPG file to the monitored folder and then you copy 'folder.jpg' to the folder?

peke

2011-09-13 00:15

developer   ~0027650

You are right.

a) Refresh Issue
b) Not same series, with single file is OK

Verified 1431