View Issue Details

IDProjectCategoryView StatusLast Update
0008079MediaMonkey (current)DB/FileMonitorpublic2011-09-17 23:05
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0008079: Failed DB updates from MM3 to MM4 in some cases
DescriptionUpgrades from MM3 to MM4 can result in some db corruption in some cases.

For the MM3 DB posted to the ftp server (which seems to work fine in MM3), after upgrading to MM4, when sending any of the tracks below to a playlist, a DB error results:

Adamo - Dolce Paola
Adamo - Les Filles Du Bord De Mer
Adamo - Vous Permettez Monsieur
Astrid Nijgh - Ik Doe Wat Ik Doe
Beatles - Wild Honey Pie
Beatles - Yellow Submarine
Beatles - Yer Blues
Beatles - You Never Give Me Your Money
Beatles - You Won't See Me
Captain Beefheart And His Magic Band - When Big Joan Sets Up
Captain Beefheart And His Magic Band - Wild Life
Carcass - Arbeit Macht Fleisch
Carcass - Blind Bleeding The Blind
Carcass - Buried Dreams
Carcass - Cadaveric Incubator Of Endo Parasites (Live)
Carcass - Crepitating Bowel Erosion (Live)
Carcass - Cross My Heart
Carcass - Don't Believe A Word
Carcass - Firm Hand
Carcass - Generation Hexed
Carcass - Go To Hell
Carcass - Keep On Rotting In The Free World
Carcass - R**k The Vote
Carcass - Tomorrow Belongs To Nobody
Cardigans - Lovefool
Cardigans - My Favourite Game
Carel Kraayenhof - Adios Noniño
Carl Douglas - Kung Fu Fighting
Carl Perkins - Blue Suede Shoes
Carlos Mendes - Verão
Carlos Santana & Willy Nelson - They All Went To Mexico
Carly Simon - Coming Around Again
Carly Simon - It's Hard To Be Tender
Carnal Forge - Butchered, Slaughtered, Strangled, Hanged
Carnal Forge - Fuel For Fire
Carnal Forge - Hand Of Doom
Carnal Forge - Totalitarian Torture
Carnal Leftovers - Caffeine Induced Insomnia (Live @ Stonehenge '04)
Carnal Leftovers - Fluffy Little Teddybears (Live @ Stonehenge '04)
Carnal Leftovers - Submission
Carnal Leftovers - The Green Solution
Carole King - You've Got A Friend
Children Of Bodom - Next In Line
Clash - London Calling
Claudio Villa - Addio, Addio
Cliff Richard - A Girl Like You
Cliff Richard - A Voice In The Wilderness
Cliff Richard - Congratulations
Cliff Richard - Dancing Shoes
Cliff Richard & The Young Ones - Living Doll
Cradle Of Filth - Haunted Shores
Cradle Of Filth - Heaven Torn Asunder
Cradle Of Filth - The Forest Whispers My Name
Cradle Of Filth - To Eve The Art Of Witchcraft
Creedence Clearwater Revival - Proud Mary
Creedence Clearwater Revival - Suzie Q (Part 1)
Creedence Clearwater Revival - Up Around The Bend
Creedence Clearwater Revival - Who'll Stop The Rain
Exodus - Impaler
Forseti - Der Graue König
Forseti - Empfindsamkeit
Forseti - Lichterflug
Gerard Cox - t Is Weer Voorbij Die Mooie Zomer
Gerry & The Pacemakers - Ferry Cross The Mersey
Gorgoroth - Prosperity And Beauty
INXS - Never Tear Us Apart
Iron Maiden - The Number Of The Beast
Iron Maiden - The Trooper
Kreator - Lost
Kreator - Phobia
Kreator - Tormentor
Libera - Recordare
Mike Oldfield - Innocent
Mike Oldfield - Pictures In The Dark
Mike Oldfield - Shadow On The Wall
Mike Oldfield - Tubular Bells (Theme From The Exorcist)
Mike Oldfield & Maggie Reilly - To France
Nightwish - Beauty Of The Beast
Nightwish - Planet Hell
Nightwish - The Siren
Nightwish - Wishmaster
Opeth - Ending Credits
Opeth - Hope Leaves
Opeth - Into The Frost Of Winter
Opeth - Karma
Opeth - Madrigal
Opeth - To Rid The Disease
Opeth - White Cluster
Pet Shop Boys - It's A Sin
Pet Shop Boys - It's Alright
Pet Shop Boys - Left To My Own Devices
Pet Shop Boys - Suburbia
Pet Shop Boys - West End Girls
Primordial - Gallows Hymn
Primordial - Sons Of The Morrigan
Primordial - The Song Of The Tomb
Queen - Brighton Rock
Queen - Crazy Little Thing Called Love
Queen - Don't Stop Me Now
Queen - Flash
Rolling Stones - Heart Of Stone
Rolling Stones - Honky Tonk Woman
Rolling Stones - It's All Over Now
Rush - Working Man
Sabrina - Boys (Summertime Love)
Santana - Everything's Coming Our Way
Santana - Evil Ways
Santana - Jingo
Santana - Persuasion
Santana - Samba Pa Ti
Santana - Se A Cabo
Shadows - Apache
Shadows - Atlantis
Shadows - Dance On
Shadows - Dear Old Mrs. Bell
Shadows - Foot Tapper
Simple Minds - Promised You A Miracle
Sniff 'n' The Tears - Driver's Seat
Solomon Burke - The Other Side Of The Coin
Sonata Arctica - Black Sheep
Sonata Arctica - Silver Tongue
Sonata Arctica - The Misery
Spinvis - Aan De Oevers Van De Tijd
Spinvis - Het Laatste Wonder
Spinvis - Het Voordeel Van Video
Spinvis - Lotus Europa
Spinvis - Ronnie Gaat Naar Huis
Spinvis - Smalfilm
Spiritual Front - Border
Tracy Chapman - Fast Car
Ultravox - The Voice
Ultravox - Vienna
Vangelis - Hymne
Vangelis - Jerusalem
Vangelis - Pulstar (Short)
Vangelis - Theme From "Antarctica"
Vangelis - To The Unknown Man (Short)
Vangelis, Dudley, Horn, Jeczalik, Hüner, Schneider, Hammer, Jarre & Moroder - The Inter-Galactic Cruise (Radio Mix)
Wham! - Freedom
Wham! - Last Christmas
Additional InformationFull user report at: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=58945

Also: the following issues of failed updates to Collection settings might be related? http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=58944
TagsNo tags attached.
Fixed in build1406

Relationships

related to 0008077 closedpetr Player initialization error on DB Upgrade 
related to 0007962 closedjiri A bug in SQLite 3.6.18 -> update to the latest version 
related to 0008122 closedLudek In rare case, upgrade to MM4 --> 100% CPU utilization 

Activities

Ludek

2011-07-06 18:11

developer   ~0026585

Last edited: 2011-07-06 19:17

View 4 revisions

I can reproduce, but hard to say what could cause this. It looks like a bug in SQLite, I have tried suggestion from here: http://sqlite.phxsoftware.com/forums/p/650/9958.aspx#9958 to not execute triggers in transaction, but it didn't help. Most probably the DB was somehow corrupted also in MM3 and therefore the errors after the DB update appear.

Assigned to Jiri for review.

jiri

2011-07-07 16:17

administrator   ~0026609

Last edited: 2011-07-07 16:53

View 2 revisions

The issue can be reproduced with SQLite 3.7.6.3, while it isn't present in 3.6.18. It's hard to say what's the root of the problem, but it doesn't seem to be related to MM.DB conversion, since the problem can be reproduced even in MM 3.x in case the newer SQLite3MM.dll is used. I.e., it looks like the DB is somehow corrupted.

jiri

2011-07-07 19:46

administrator   ~0026614

As discussed over IM, Petr will try to create a small app that would make a new clean DB out of existing ones (in order to get rid of possible corruption of internal DB structures).

rusty

2011-07-11 15:42

administrator   ~0026715

The tool is working well. Let's incorporate it into the DB Optimization (Complete) routine.

petr

2011-07-12 23:46

developer   ~0026752

Implemented in 1406

peke

2011-09-17 23:05

developer   ~0027804

Verified 1433