View Issue Details

IDProjectCategoryView StatusLast Update
0007563MediaMonkey (current)Properties/Auto-Toolspublic2011-07-11 01:21
Reporterrusty 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0007563: Thumbnails override Artwork
DescriptionIn build 1355, artwork that is stored to the same directory as a video series is not shown in the artwork tab for the video file--the auto-generated thumbnail is shown instead.

Moreover, if the user manually tries to add the artwork for the video, it doesn't get added!!

In the attached log, tried to save artwork to weeds502:
-Line 0000071:0000100: edited artwork and attached image from the directory containing weeds502. The act of attaching the image kept MM busy until line 0000012:0000386
-Line 0000106:0000400: checked the file to see if the artwork was updated. It wasn't.

Finally, users have reported the same issue occurring with Podcasts:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=55663
TagsNo tags attached.
Fixed in build1373

Relationships

related to 0007736 closedpetr Art & Details window problems 
related to 0006930 closedpetr Art and Details window often fails to show Album Art 
related to 0007780 closedLudek Images in podcast folders aren't assigned to Podcasts on download 
related to 0008216 closedpetr Thumbnails are associated to tracks that have no Art 

Activities

rusty

2011-03-22 19:10

administrator  

thumbnail_overrides_artwork.LOG (46,624 bytes)

petr

2011-04-18 21:55

developer   ~0024370

Artworks stored in same folder are managed different for video files (based on 0007060). Is the artwork file named same as the video, or is it 'folder.jpg' named ?

lowlander

2011-04-29 19:54

developer   ~0024582

I have folder.jpg in Podcast folder and thumbnail generation turned off (they're MP4 video podcasts). Neither non-downloaded nor downloaded Podcasts show the folder.jpg as Art.

What I'm looking for is a way to assign a default image to all episodes of a specific podcast. One way would be to assign the feeds default or episode image when available and another would be by having a default image in the Podcast folder. The first would be the easiest as it requires no user interaction for it to happen (but would require a way to disable it for those who don't want this).

petr

2011-04-30 20:26

developer   ~0024648

Fixed art showing in AA view

lowlander

2011-05-01 04:47

developer   ~0024678

Last edited: 2011-05-09 20:20

View 3 revisions

1) With folder.jpg in the Podcast's folder it doesn't associated with downloaded episodes on 1368.

Note:
- Manually adding folder.jpg to only downloaded episode doesn't add to other episodes downloaded afterwards. (kind of expected)
- Having it apply to all files on Album/Series doesn't add Art to another downloaded episode with same Series.
Art View doesn't show art either (which is expected as none is associated).

Edited by Rusty to clarify which items are bugs.

lowlander

2011-05-01 20:59

developer   ~0024701

Last edited: 2011-05-09 20:21

View 3 revisions

2) If Generate Thumbnails is disabled, you download an episode and then re-enebale Generate Thumbnails it seems to sometimes fail to generate thumbnails for episodes without Art associated. I also saw this when removing thumbnails from Episodes. I haven't found the trigger yet and am currently unable to reproduce.

Note:
- If Generate Thumbnails is disabled and you attach Art to a Vodcast and then re-enable Generate Thumbnails, MediaMonkey does respect the existing attached Art and doesn't generate the thumbnail.

Edited by Rusty to clarify which items are bugs.

rusty

2011-05-09 20:26

administrator   ~0024981

Last edited: 2011-05-09 20:32

View 3 revisions

As pointed out by Lowlander, the original bug isn't fixed (i.e. when scanning files with folder.jpg in the directory, thumbnails still override folder.jpg), but even stranger is that:

3) When viewing Properties > Artwork for any track in a series, upon deleting the thumbnails via the Properties > Artwork:
-the art view still shows the thumbnails
-upon selecting a track, the art&details window briefly displays the deleted thumbnail and a second later, displays folder.jpg.

rusty

2011-05-09 21:45

administrator   ~0024985

Note re. build 1371:
1) The bug is still open (i.e. thumbnails are created for the video rather than based on the folder.jpg file).

3) This is mostly solved i.e. after deleting the thumbnails, they are truly deleted--except for the fact that the Art View doesn't refresh to show this--the user has to switch nodes to trigger a refresh.

rusty

2011-05-09 21:45

administrator  

bug7563.LOG (132,296 bytes)

petr

2011-05-10 21:36

developer   ~0025049

Fixed in 1372

rusty

2011-05-11 05:00

administrator   ~0025061

Tested 1372 and it's working correctly now, however, performance is really bad--it takes about 10 seconds for 10 episodes to display in AA view (tracks are from the network).

I've attached a debug log that illustrates this (clicking Weeds seasons 1-4 renders thumbnails almost immediately. Cliking season 5 takes ~10s for all the episodes to be displayed).

rusty

2011-05-11 05:01

administrator  

bug7563_performance.LOG (32,825 bytes)

petr

2011-05-11 10:02

developer   ~0025074

Tracks should be visible immediately, but with no art.
This 10s delay was just for a first time, right ? It's because it need to 'load' and generate cache for each video file (so need load folder.jpg from the network 10 times).

rusty

2011-05-11 17:36

administrator   ~0025087

No--the delay is everytime Locations>Path>Weeds Season 5 is clicked.

petr

2011-05-11 19:41

developer   ~0025092

Fixed in 1373

lowlander

2011-05-12 19:21

developer   ~0025135

Is it supposed to work and if so with what settings that if you have a folder.jpg in the download folder that any newly downloaded Podcasts are automatically associated with this folder.jpg? This is not working here, but I'm wondering if it's supposed to?

petr

2011-05-12 20:18

developer   ~0025139

Last edited: 2011-05-12 20:23

View 2 revisions

All tracks in same folder must have same album/series to use folder.jpg as a cover for them. Also i'm not sure how it's with downloaded podcasts. Are they added to DB using AddToDatabaseRec function, Ludek (it's the function where covers are assigned to tracks during scan) ?

lowlander

2011-05-12 21:41

developer   ~0025140

Album/Series would be Podcast and they all have the same value.

Ludek

2011-05-13 12:49

developer   ~0025160

Last edited: 2011-05-13 13:36

View 5 revisions

Podcasts episodes often include artwork embedded in tag and MM is not downloading any folder.jpg to podcast folder. I don't think that newly downloaded Podcasts should be automatically associated with folder.jpg (which needs to be added manually by user anyway and it is very rare case).

lowlander

2011-05-13 14:43

developer   ~0025163

Vodcasts I've subscribed to don't contain embedded Art, Podcasts might though. I would be satisfied with:
1) Using folder.jpg in download folder
2) Using embedded image
3) Using Podcast episode image
4) Using Podcast feed image
This might also be the best sequence to determine which image should be automatically associated, otherwise a setting for Podcasts to determine what image or what sequence should be used would work better (that would probably need to be deferred to 4.1 as it requires new strings).

rusty

2011-05-13 16:51

administrator   ~0025170

Last edited: 2011-05-13 16:52

View 2 revisions

Note: I've opened a new bug 0007780 re. podcasts to cover the issue raised by lowlander.

peke

2011-07-11 01:21

developer   ~0026697

Verified 1404